SwedeSpeed - Volvo Performance Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2,439 Posts
Discussion Starter · #1 ·
Is sensor 1 bank 1 the front or rear sensor? I'm guessing front.

Just replaced both of mine with OEM Bosch units from IPD and I'm pretty sure the new front one is defective.

Prior to the change I was getting the O2 sensor slow response code every few months

After i'm now getting P0130 and P0135 which are

02 Sensor Circuit Malfunction (Bank I Sensor 1)

and

Oxygen O2 Sensor Heater Circuit Malfunction (Bank 1, Sensor 1)


So clearly the bank 1 sensor 1 sensor isn't happy. It's not adjusting once at temperature(135) and it's just flat out failing throwing the 130 code.



IPD said to check the wiring but it all looks good, if it were the wiring as well the old sensors would have had the same codes.

IPD told me if I buy a replacement sensor and send the old one back and it's found to be defective, they'd refund me the price of one of them so that's fair enough. I just need to double check that bank1, sensor 1 is the front sensor.

Man I hope I can get it out...I got it out before with the oil pan off so there was a lot more room underthere.

Thanks!
 

·
Registered
Joined
·
2,439 Posts
Discussion Starter · #2 ·
one time bump....
 

·
Registered
Joined
·
71 Posts
I'm not sure sensor is which but a random thought, if you still have your original O2 sensors swap it back in to see if the codes stop popping right away.
I know you said it is a pain to swap the sensors with the oil pan installed, but it is just a random idea to confirm your thoughts.
 

·
Registered
Joined
·
63,541 Posts
IPD said to check the wiring but it all looks good, if it were the wiring as well the old sensors would have had the same codes.

Thanks!
You can't tell by looking
If you bought a blue box OEM Volvo rear sensor, they include the small rear 02 sensor harness.
They get HOT and fail
 

·
Registered
Joined
·
2,439 Posts
Discussion Starter · #6 ·
You can't tell by looking
If you bought a blue box OEM Volvo rear sensor, they include the small rear 02 sensor harness.
They get HOT and fail
Bosch ARE the oem sensors as far as I know. And both of my sensors DID come with their harness all the way forward to the big plug. I didn't cut/splice/add anything, just plug and go.
 

·
Registered
Joined
·
1,804 Posts
he is talking about the adapter harness there is a bulletin for.....they come with the blue box sensors but not the Bosch aftermarket.
 
1 - 7 of 7 Posts
Top