SwedeSpeed - Volvo Performance Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Need some help fellas. I posted on a couple other sites to see if anyone has some ideas on this.
Well, lets see if anyone can help me with this problem. I have a 2003 Volvo S60 T5 that I bought from a co-worker. He was the original owner. My friend was having a couple issues and decided to part ways with the car. First issue was a intermittant drivers information module. I took it out and had it fixed. Now the other problem.
I have had the car a couple weeks and have had a couple intermittant no start issues. I just went thru this with my daughters 02 S40 and it ended up being the park/reverse/neutral switch. So, that is what my first conclusion arrives at: PNP switch. I changed it yesterday and right after finishing the job, I started it up. Ran it for about 10 minutes and turned it off. Now I get NO start at all. All the lights come on, radio, etc and when turning key headlights go out. No click or anything. Battery terminals are pristine. I took wires off starter and cleaned them up even though they looked excellent. First owner had the battery and starter changed less than a year ago. I tried a different key along with locking unlocking door trick, no luck. I suspect immobilizer ring but not sure if thats it. What about ignition swtch, could it also be bad? Can I just change that or does it invlove new keys with programming? One other concern is I took lower plastic piece off of steering column to get a look at the immobilizer ring. When I removed the 3 torx screws and lowered plastic piece I seen a piece of metal with a spring on the end of it. It's approx one inch long. I looked and can't see where that could have came from. Any ideas? Thanks!!!
 

·
Registered
Joined
·
209 Posts
I'm having the same issue with my 04 S60 R. When I put the key in the ignition the radio, headlights windows,etc work. Just no start at all also have all the massages pop up on the dash. I feel like it could be the CEM but can't be for sure. Hope someone out there can help with this issues.
 
1 - 2 of 2 Posts
Top