SwedeSpeed - Volvo Performance Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
I have searched various threads but I do not see an answer to this question:

I have a '99 C70 Convertible with a SC-816 head unit and a 4 x 60 amplifier. I am getting no sound from the system. The head unit is powered all all functions seem to work but no sound. The amplifier is powered and all fuses are good (2 in fuse panel, 1 on amplifier). I have checked all connections.

Can anyone suggest a troubleshoot or is it time to replace the system?
 

·
Registered
Joined
·
406 Posts
Hello,

I have tried to swap a SC-816 from a 1999 V70 and a SC-900 from my 1998 C70. ANd vice-versa.

It appears that the SC-900 will not work in a V70, nor the reverse, mainly (I was told by a friend working at a dealership) because of the dolby and other wirings leading to the speakers and amplifier (I dont recall about the actual details here).

The SC-816 was not (at least in the US and Canada markets) a stock sound unit for HPT versions (thats came with SC-900 or SC-901). In your case, I would guess you or a previous owner have swapped it in.

You will have to get an SC-900 or -901.
 

·
Registered
Joined
·
2,889 Posts
If the car has an external amp, ANY Volvo HU with an AMP connector will work.
Since your C70 has the big amp in the back, you should be good to go.

( It sounds like Lucas tried to use a 900 series HU in a car WITHOUT an amp.
The 900/901's don't have an internal amp - they have to have the outboard.
An 816 has it's own built in amp, but may also be used with an external amp,
but you have to plug in the AMP cable or you won't get sound. And FWIW, Dolby
is not involved in that part of the equation -The 816 should have worked ).

The C70 4 x 60w has several things you can easily check to find out what's up.
First, get out a meter. Just looking at a fuse is inconclusive. Be sure that power
is present at both of the nibs embedded in the tops of the fuses.

If you have power there, unplug the round 6 pin DIN from the amp and
check for the remote turn on power from the HU. With the key and the
HU on, you should have 12 volts at the center pin of the DIN cable.

Be very careful not to short the center pin to any of the others
with your meter probe!
That would make smoke come out... :eek:

Post back with findings. :thumbup:
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #4 ·
--------------------------------------------------------------------------------





Thanks BEJinFbk,

We confirmed the HU is good by swapping with another car. The amp show signs of water entering the unit and we assume the amp is toast. We will do your tests to validate power to the amp. If good, looks like a new amp or may upgrade the package.
 

·
Registered
Joined
·
406 Posts
If the car has an external amp, ANY Volvo HU with an AMP connector will work.
Since your C70 has the big amp in the back, you should be good to go.

( It sounds like Lucas tried to use a 900 series HU in a car WITHOUT an amp.
The 900/901's don't have an internal amp - they have to have the outboard.
An 816 has it's own built in amp, but may also be used with an external amp,
but you have to plug in the AMP cable or you won't get sound. And FWIW, Dolby
is not involved in that part of the equation -The 816 should have worked ).

The C70 4 x 60w has several things you can easily check to find out what's up.
First, get out a meter. Just looking at a fuse is inconclusive. Be sure that power
is present at both of the nibs embedded in the tops of the fuses.

If you have power there, unplug the round 6 pin DIN from the amp and
check for the remote turn on power from the HU. With the key and the
HU on, you should have 12 volts at the center pin of the DIN cable.

Be very careful not to short the center pin to any of the others
with your meter probe!
That would make smoke come out... :eek:

Post back with findings. :thumbup:
Thanks for the details. Learning new stuff everyday!
 

·
Registered
Joined
·
2,889 Posts
Water and electronics are usually a disappointment.
Happily, the C amps are pretty easy to come by.
Shop around a bit and you should find good deals.
Maybe even upgrade to the 4 x 100w?
 

·
Registered
Joined
·
7,614 Posts
I'm planning on selling mine (4x100) as soon as I get it out of the car, let me know if interested.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #8 ·
Rather than stick to the dated SC-816 HU, I have bought a Kenwood DNX5190 Head Unit with Bluetooth and GPS as well as an Alpine MRP-F300 Amp.

Doing the install now. Removed the two plastic slide rails from the console housing and the head unit now fits. Next is to get the proper wiring harness to interface to the Volvo feeds. Should be operational in a week.
 
1 - 8 of 8 Posts
Top