SwedeSpeed - Volvo Performance Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi all,<br>New to the forums and Volvo's!!<p><br>I've just bought a 98 v70 non turbo a couple months ago from a friend. It has 197,000 miles on it. Anyhow, got into this morning and the CEL was on. Took it to the local FLAPS to get the codes read. And this is what they printed out for me.<p>PO505<br>001- Vacuum leak on engine<br>002-Dirty throttle body<br>003-IAC motor defective<br>004-Poor electrical connection to the IAC valve<p>PO172<br>001-If bank one and two codes set together suspect fuel pressure or MAF<br>002-02 sensor defective<br>003-Ignition misfire repair<br>004Fuel injectore problem<p><br>Before I start buying any parts, I'm going to check for the obvious things first, like vacuum leaks. Are there any vacuum hose that are known to go bad. If so, which ones and could you please tell me the location.<p>Any other suggestions I would appreciate also. This is my first volvo so I don't know awhole lot about them.<p>BTW- I love this car, it's in really good shape for the mileage and year. Has had the timing belt done, all new front end, brakes are good. Just looking to lower it and put a set of wheels on it. <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0"> <p><br>Thanks alot,<br>Curtis<p>
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #2 ·
Also need to mention, the car runs fine w/ the CEL ON.<p>Gonna check m mileage to make sure I'm still getting around what I've always gotten.<br>
 

·
Registered
Joined
·
547 Posts
Re: (Bigcfromcinci)

Can't post pics from work, But I will post the complete vaccum diagram when I get home. Check first for a broken vac line on the end of the intake manifold passenger side behind the powersteering pump. <p>IAC motors frequently get clogged and can benfit from a good cleaning. Bay 13 on volvospeed or matthews volvosite both have some great writeups on how to do this easy maint. item. <br>Welcome to the forum!<p>Dirty MAF sensores are common get some specific MAF cleaner from an auto parts store an give that a tray (often does the trick) <p>When was the last time the plugs/ wires/ cap/ & rotor were changed?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Thanks alot heavyiron! I appreciate the help.<p>I'll check into what you suggested this weekend. The car was recently tuned up no longer than 4 months ago.<p>If it's a dirty maf will the CEL go off on it's own after I clean it if that's the problem.?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
Well I had time to take a peek at it after work today. First thing I notice is this vaccuum hose broken off coming off the front of the manifold.<br><A HREF="http://CurtisHelton.zenfolio.com/p744704339/e16d49631" TARGET="_blank">http://CurtisHelton.zenfolio.c...49631</A><p>I shortened the hose and stuck it back on. Definately idles much smoother now. Will buy a new hose and clamp tomorrow.<p> The CEL is still on. Do I have to scan it again to reset the codes?<p>Thanks for the help.<p><br>I bought some maf cleaner. I'm going to go ahead and clean that while I have the time.
 

·
Registered
Joined
·
63,543 Posts
Re: (Bigcfromcinci)

Don't just spray that sh*t in there.<br>Most good Volvo mechanics remove it and turn it sideways
 

·
Registered
Joined
·
547 Posts
Re: (JRL)

Looks like you found the problem. That is a REALLY long line that goes all the way behind the intake manifold to the PTC nipple on the compressor sid eof the turbo. Total PITA to change. Here is that vacum diagram I was talking about <br><IMG SRC="http://i292.photobucket.com/albums/mm37/heavyiron1978/98s70t5vachosroute17pr.jpg" BORDER="0">
 
1 - 8 of 8 Posts
Top