SwedeSpeed - Volvo Performance Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hey guys name is Martin, am new to the forum, came from an Audi into a new
To me 2013 Volvo C30 T5, bought it from auction was hit in suspension and plan to rebuilt it and enjoy driving it, has low mileage 79,000kms if I need any help I’ll be sure to reach out to you guys. I hope I made the right choice buying this vehicle, I wanted a hatchback and seems like a nice choice
119022
119023
119024
 

·
Registered
Joined
·
2,712 Posts
Good luck! remember these share platforms with the Ford focus and Mazdaspeed 6, so suspension parts should be plentiful!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Are you sure? I never knew that at all but good to know forsure, also need to figure out why it stalls when I start it I get an error message something about the anti skid plate
I’ll take a picture
 

·
Registered
Joined
·
27 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Once i fix it and get it inspected maybe in the summer I’ll start modding

cant seem to figure out what this plug broke off of ?
 

·
Registered
Joined
·
2,712 Posts
That is one of the wires to the fog lights, there's one on each side, these cars all come pre-wired for fog lights, if your car does not have them installed they are clipped onto the bottom of the front bumper. the piece that is stuck on the end is part of your bumper lol.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
Ah alright thanks for letting me know, so I can replace the grills with factory foglights ?
Is there a foglight switch to turn them on already in the car ? I never noticed it
 

·
Registered
Joined
·
2,712 Posts
If you want to add the fog lights you need a new light switch, the fog lights, bulbs, bezels and a software update either from the dealership or using VIDA.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter #10
Good to know thanks
Also getting this message? Could it be due to it being hit and bent control arm? All suspension I’m changing anyways just trying to rule everything out, I know oil light abs and traction probably due to transmission seen oil pouring when I fired it up but already found transmission for good price and will be doing work myself
119218
 

·
Registered
Joined
·
2,712 Posts
My guess is it’s a damaged wheel speed sensor, the car cuts torque if it senses the wheels break loose, the wheel speed sensor being damaged might trigger this function and disable the stability control.

This is all assumption, a proper scan from a dealership could tell you more.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,374 Posts
C30 looks good in the pics. nice that you have the leather interior instead of the usual 'fabric' crap. Got the suspension & transaxle replaced yet? Once the obvious work is done & you can drive it, it should be easier to diagnose anything remaining. The current error/warnings could just be residual from time of accident.
 

·
Registered
Joined
·
1,767 Posts
Welcome to the club. Looks sharp.
 
  • Like
Reactions: NvMySi

·
Registered
Joined
·
7 Posts
Discussion Starter #14
C30 looks good in the pics. nice that you have the leather interior instead of the usual 'fabric' crap. Got the suspension & transaxle replaced yet? Once the obvious work is done & you can drive it, it should be easier to diagnose anything remaining. The current error/warnings could just be residual from time of accident.
Thanks that’s what I thought, nope not done yet noticed the transmission line cracked and oil was pissing out so order that as well, order new control arm, sway bar link, cv axle, new front brakes and rotors and picked up a used strut and spindle assembly all together with caliper, will be installing most of it this week hopefully, won’t be able to drive it until gets inspected.
And yes love the leather another reason why I purchased it
 
1 - 14 of 14 Posts
Top