SwedeSpeed - Volvo Performance Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
picked up my first 850 turbo last night its a pretty high miles car 282k lol but drives like a champ and aside from being down on power or so it seems is in very good shape
it was a one owner car serviced at a volvo dealer it entire life most recently had a timing belt installed at 281k
it has fresh plugs and wires and fuel filter i have checked over all the vac lines very carefully
it just seems way down on power to me for being 221hp i realize it may just be a little tired but it has zero blowby at all no missing no sputtering nothing that indicates a mechanical issue to me
it was a rather old lady that owned it is it possible that the wastegate is stuck partially open ? the turbo guage moves about 1/4 to the right of center at WOT.
or could there be another problem with the boost control system or the bypass valve thats built into the compressor cover ?
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #2 ·
picked up my first 850 turbo last night its a pretty high miles car 282k lol but drives like a champ and aside from being down on power or so it seems is in very good shape
it was a one owner car serviced at a volvo dealer it entire life most recently had a timing belt installed at 281k
it has fresh plugs and wires and fuel filter i have checked over all the vac lines very carefully
it just seems way down on power to me for being 221hp i realize it may just be a little tired but it has zero blowby at all no missing no sputtering nothing that indicates a mechanical issue to me
it was a rather old lady that owned it is it possible that the wastegate is stuck partially open ? the turbo guage moves about 1/4 to the right of center at WOT.
or could there be another problem with the boost control system or the bypass valve thats built into the compressor cover ?
interesting development washed and degreased the engine bay today since it was horridly filthy the car suddenly has tons more power and runs way better but has high idle and the boost/vac guage does not work guess is i have a ton of vac lines to trace and check over
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
little bit of good news on my low power issue
washed and degreased the engine bay today since it was horridly filthy and i cant stand that
on my way home it ran horrible since everything was wet came back out a few hours later and started looking everything over and found some vac line issues
the line from the plenum to the turbo inlet pipe was off( fixed that real easy)
there was a small hard plastic line alongside the pcv line going into the inlet plastic tube that was cracked (repaired also)
also cleaned the maf sensor, replaced fuel filter, pulled plugs and checked the gap , seafoamed the engine thru a vac line ( holy smoke bomb lol )
car runs 3000% better feels light on its feet now and pretty peppy now to install my fancy electronic boost controller and set it to 13psi and have the cat deleted
i also painted the wheels grey, since they were shot from brake dust eating the factory coating to hell
 

·
Registered
Joined
·
14,426 Posts
Congrats on the new to you T5!

Sounds like you are making great progress on the engine. Could be the wastegate. There are great instructions on this and other sites as to how to adjust it. Another area to check is the vacuum tree under the throttle cable cover if you haven't checked yet. With those miles it may just be that the turbo is alittle tired.

How is the suspension, steering, brakes?

Post some pics if you get a chance.

Welcome aboard.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
suspension steering and brakes are all in great shape it seems extremely well maintained it drives straight and smooth no clunks bangs or rattle`s
i went over the entire vac system today and sprayed carb cleaner around the engine bay seeking other leaks and didnt find anything else
tomorrow im gonna tackle the cluster bulbs since nothing but the lcd works and i got the wrong bulbs got for the illumination behind the speedo, tach, and other guages
after getting the car running correctly im super happy with it , i was honestly a bit underwelmed by it when i first got it since it was painfully slow lol
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 · (Edited)
dash lights fixed, issue with dome lights fixed ( door switch was stuck )
now onto the rear passenger side window that goes down but not up lol
next project aside from the window issue is painting the front window trim black since the coating has all come off and fixing the rear bumper brackets and getting the bumper up where its supposed to be
 

·
Registered
Joined
·
1,674 Posts
How is the pcv system and how are the inter cooler piping hoses?
 

·
Registered
Joined
·
574 Posts
FYI
I always clean out the inside of distributor cap after a good "under hood cleaning" and I always find it wet after cleaning.
 
1 - 8 of 8 Posts
Top