SwedeSpeed - Volvo Performance Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
I bought an '07 3.2 AWD about a week ago (Willow green, pretty well optioned including premium sound and third row air, etc.) with 119k miles for $12k. It is in remarkably immaculate shape and came with a complete service history (basically nothign ever wrong with it), so I think I got a pretty good deal.

Since it is new to me I'm probably a little more critical than the original owner was about some little things, and I'm having a couple of issues: The doors do not want to lock like they should, there is a little bit of darting at high speeds (~80mph), and the drivers side mirror breakaway hinge is loose. I assume I can dive in and figure out what is going on with the drivers side mirror hinge pretty easily. The darting is probably caused by the control arm bushings or a tie rod end somewhere, and as soon as I can get it up on a lift I can probably get that sorted out. The perplexing one to me is the door lock situation.

Both of the passenger side locks do not seem to want to lock or unlock electronically with any method I try. With one of the remote keys the other two doors lock and unlock just fine (with the other it is hit or miss, so I assume that key fob remote is on it's way out). Locking and unlocking all the doors with either key at the drivers side door does not get those two doors to lock or unlock, but if I lock or unlock either of them at the doors themselves they work perfectly -- no binding or rubbing issues from what I can tell. I assume this means the door lock actuators are bad. Is this a common problem? Is there something else electrical it might be to cause them both to go bad? If so, how do I determine what the problem is? I still need to try a battery reset to see if that clears anything up. (Do I really need to have the key in position II when I reconnect the battery?) I don't live near a dealer, so I can't easily just get it hooked up to a VIDA, but I will if that's what I need to do. Any help would be appreciated (about any of the problems, but especially the locks). Thanks.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
I'll check the connectors, but I'm guessing that's not the problem since both door locks are having problems and I can't imagine both connectors coming loose, although stranger things have happened. I've seen a few other posts with similar problems, but nobody seems to have any real answers about what's going on. It seems like it could be any number of things. Loose connectors is one that I hadn'e run across yet. I'm going to pull the door panels when I get a chance and hopefully it's something simple like that.
 
1 - 3 of 3 Posts
Top