SwedeSpeed - Volvo Performance Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
New member here. Has anyone had this problem with an easy fix bought my s60 yesterday and on the drive home it says the blis needs service. Hoping I can pull a fuse and fix it but I also can’t find the trunk fuse box where the blis fuse is located. Any help is appreciated!
 

·
Registered
Joined
·
530 Posts
New member here. Has anyone had this problem with an easy fix bought my s60 yesterday and on the drive home it says the blis needs service. Hoping I can pull a fuse and fix it but I also can't find the trunk fuse box where the blis fuse is located. Any help is appreciated!
Unless you live far from the dealership, I would take the car back and get the issue resolved as soon as they can fit you in. They shouldn't charge at all since this is a brand new car.
 

·
Registered
Joined
·
283 Posts
New member here. Has anyone had this problem with an easy fix bought my s60 yesterday and on the drive home it says the blis needs service. Hoping I can pull a fuse and fix it but I also can't find the trunk fuse box where the blis fuse is located. Any help is appreciated!
Congrats on the new car; good choice. Don't be a DIY on a new car; have dealer service fix it. My new S60 needed a new water pump after only one month. With new model launches, things happen sometimes. I do recall receiving a BLIS error message as well early only; it went away by itself before I could address.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Thanks guys I have a service appointment set up for Friday. However I was hoping to diagnose the problem before then. Praying it’s just a software update. Sucks to buy a new car and have it break on the 300 mile drive home.
 
1 - 6 of 6 Posts
Top