SwedeSpeed - Volvo Performance Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I am hoping that someone can point me in the right direction...<p>I have a 2006 V50 T5 auto with 1,300 km (~810 miles). I had the check engine light come on twice already. Once at ~ 100 km (60 miles) and the second time at 1,100 km (680 miles). In both cases it definitely wasn't the gas cap or filling the car while the engine is running.<p>Apparently (according to the dealer), I have an emission system leak which they will troubleshoot when I bring back the car with less than 1/2 a tank of gas.<p>In addition, since the check engine light came on the second time (1,100km/680 miles) it feels that I lost a lot of the torque at low RPM. My feeling was somewhat confirmed when I drove a '06 V70 2.5T AWD which is rated at 10 hp less at 5,000 RPM and same torque (236 ft-lb @ 1,500 RPM) and felt that the V70 had way more power than my V50 T5.<p>I haven't been driving the car for more than 1 month... can someone connect the dots here? Could it be that the turbo stopped working or something? Does the computer have a code that would tell the tech there is a problem there?<BR><BR>
<i>Modified by dgionet at 6:11 AM 8-10-2006</i>
 

·
Registered
Joined
·
324 Posts
Re: New 2005 V50 T5 emissions and power problem (dgionet)

Computer likely put it into some sort of limp mode, to avoid more damage. ONce the dealer figures out the problem, all should be well again.<p>I just spent 3 days in a V70 2.5T AWD, and you're right, your V50 should kick it's ass. My 6 speed V50 felt like an F1 car after the V70.<p> Al
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks! Actually, you are correct. The dealer reset the flag when they returned the car and after about 1 day, the power came back to expected levels.
 
1 - 3 of 3 Posts
Top