SwedeSpeed - Volvo Performance Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello everyone. Looking for some help with a current engine code P0430 in my 2007 S80 V8 @101k miles (B8444S). I checked the freeze frame data for the code, and the voltage on the Bank 2 Sensor 2 was significantly lower than on Bank 1, and slightly erratic in comparison. Already Checked fuel trims. Long and Short are consistent. No Misfires. Smooth idle. Only thing I've done different in the past month is using 91 instead of 93 octane fuel (prices suck right now).

I plan to run some Seafoam through just for fun, and go back to 93 just to cover those bases. Spark plugs will be changed soon as part of maintenance. My question is two-fold:

1) Can someone please find a diagram of this exhaust system to explain where exactly Bank 2 sensor 2 is? From what I've gathered, this engine shows three pre-cat O2 sensors, and only 1 post-cat, with nothing indicating specifically Bank 2 sensor 2 (I assume this means post-cat). I'm not entirely sure this diagram I found is accurate.
2) If I am to replace the O2 sensor, wouldn't this be a sign of the post-cat sensor throwing the code instead of the pre-cat? And does that voltage drop confirm the O2 sensor is going bad?
Font Screenshot Rectangle Technology Parallel
Rectangle Slope Line Font Parallel
Font Screenshot Number Terrestrial plant Darkness
Font Screenshot Darkness Terrestrial plant Number
Organism Line Gesture Font Elbow
 

·
Registered
Joined
·
468 Posts
Any update on this? I am getting the same code on my 3.2 but only sporadically. I cleared mine yesterday and when I checked my emissions readiness status everything passed so I dont believe my cat is bad. I have a new PCV and sensor on the way just in case.
 
1 - 2 of 2 Posts
Top