SwedeSpeed - Volvo Performance Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter · #1 ·
So I'm down to getting the damn "service engine system soon" message about once a week now insted of a new code evrey day which is nice. However the last one that seems to keep coming back is ECM-6200 Engine Cooling Fan (FC) Control Module, Faulty Signal. In my scan tool as far as I can tell the fan works. I start the car up and with live data I can see it come on at ~7%, if I flip the A\C on then it goes up to ~25%. When I turn the car off, the fan runs for a moment ad then steps down once or twice to off.

All of this to me would suggest that the module is working or that its an intermittent fault. Is this a common one? I can't really think of anything to try except to replace the entire cooling fan\module assembly but would like some opinions first.

-thanks
 

·
Registered
Joined
·
2,390 Posts
Could certainly swap in a junkyard module from a more recent car, don't need to swap whole fan I don't think

Sent from my Pixel 6 using Tapatalk
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #3 ·
I thought the P2 module was part of the fan. Isn’t it only the 2008 and newer cars that are separate? I could be mistaken, that’s just what it looked like online.
 

·
Registered
Joined
·
2,390 Posts
What year is yours? You could be right, I'm thinking of p1 I just realized

Sent from my Pixel 6 using Tapatalk
 

·
Registered
Joined
·
2,390 Posts
This module looks totally pullable to me, unless the module is on the radiator stack side... But I don't think so.


Sent from my Pixel 6 using Tapatalk
 

·
Registered
Joined
·
2,390 Posts
I can’t find anywhere that sells just the module. Only the fan as a whole.
Oh yeah I meant if you grabbed one from a junkyard. Buying it new you're looking at just the whole assembly

Sent from my Pixel 6 using Tapatalk
 
1 - 10 of 10 Posts
Top