SwedeSpeed - Volvo Performance Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
155 Posts
Discussion Starter · #1 ·
I don't get to drive 'Kajsa' that often since I live in Manhattan and don't need to drive. So in anticipation of driving down to Maryland for a long weekend I went to get my wheels aligned and rotate my tires. 4 wheel laser alignment done along with rotation and Now My car makes a loud rubbing/clicking sound from the left wheel hub. Sounds like metal is rubbing on metal or hitting the tire, sounds like a metal card in the preverbial bicycle spoke...


Anyone have an idea what it could be...I haven't taken the wheel off as I am having the car towed to the tire shop in the Morning so I can maintain the chain of custody in fault tracing and blaming. I will give the shop one opportunity to determine the problem, the solution and any additional damage. I just think my tempermental swede is lashing out for not paying attention and I think she caught me and my wondering eye as I took test drive.

Hoping its something small like the wheel clip on the hub to hold the tire while they put in the lugs, hoping I won't have to go to volvo for a big problem and get the "Why didn't you have us do your alignment and rotation"
 

·
Registered
Joined
·
1,199 Posts
Re: Need help, rubbing/grinding noise after rotation and alignment AKA Kajsa's angry (Johnnylaws60r)

Best guess is the metal 'shield' that is behind the rotor... Sometimes they get knocked when taking off the wheel and bend....

Put the car up in the air and turn the wheel by hand to see if you can find the exact location... Then bend it back...
 

·
Registered
Joined
·
1,199 Posts
Re: Need help, rubbing/grinding noise after rotation and alignment AKA Kajsa's angry (dugums)

Did you figure out if that was it???
 
1 - 3 of 3 Posts
Top