SwedeSpeed - Volvo Performance Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter · #1 · (Edited)



FYI

The front strut should be replaced at 90k miles one by one, but both are replaced. The rear are original with the car.

So where should I start with, really headache now.
 

·
Registered
Joined
·
1,891 Posts
SUM-0023 means you probably have a dead acceleration sensor, its attached to the strut tower.
SUM-0115 and SUM-0137 means your front two struts are messed up.

I could be wrong about the last two.
 

·
Registered
Joined
·
77 Posts
All these codes are yellow. That means they are old and not active now.
So clear codes and reread them after a while.

Most bad code is SUM-0244.
Often this unit gets flooded so all codes can be because of faulty unit.
 

·
Registered
Joined
·
2,199 Posts
The AUM code is probably because you have an aftermarket stereo? I do and have happily ignored that code for 3+ years now. It's benign.
 

·
Registered
Joined
·
9 Posts
I will suggest to clear all the codes, see if they came back. I had the same problem I end up replacing the BCM and SUM, remember you have to do a reload Via VIDA 2015 thru the dealer $115 for 3 days, plus each reload cost money
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #6 ·
SUM-0023 means you probably have a dead acceleration sensor, its attached to the strut tower.
SUM-0115 and SUM-0137 means your front two struts are messed up.

I could be wrong about the last two.
Thanks. The R drives really bumpy.
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #7 ·
The AUM code is probably because you have an aftermarket stereo? I do and have happily ignored that code for 3+ years now. It's benign.
Yes, it has a touch screen headunit. I was told it cost them $500 for it. Would rather they keep it original.
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #8 ·
All these codes are yellow. That means they are old and not active now.
So clear codes and reread them after a while.

Most bad code is SUM-0244.
Often this unit gets flooded so all codes can be because of faulty unit.
Thanks. I will try to erase DTC and read again.
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #9 ·
I will suggest to clear all the codes, see if they came back. I had the same problem I end up replacing the BCM and SUM, remember you have to do a reload Via VIDA 2015 thru the dealer $115 for 3 days, plus each reload cost money
It's painful. Everything cost money and not cheap at all.
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #10 ·
<a href="http://s1052.photobucket.com/user/hmz10631063/media/Mobile%20Uploads/2016-01/IMG_20160115_164811_zpsyfcqcle3.jpg.html" target="_blank"><img src="http://i1052.photobucket.com/albums/s456/hmz10631063/Mobile%20Uploads/2016-01/IMG_20160115_164811_zpsyfcqcle3.jpg" border="0" alt=" photo IMG_20160115_164811_zpsyfcqcle3.jpg"/></a>


<a href="http://s1052.photobucket.com/user/hmz10631063/media/Mobile%20Uploads/2016-01/IMG_20160115_165246_zpsu657bjyo.jpg.html" target="_blank"><img src="http://i1052.photobucket.com/albums/s456/hmz10631063/Mobile%20Uploads/2016-01/IMG_20160115_165246_zpsu657bjyo.jpg" border="0" alt=" photo IMG_20160115_165246_zpsu657bjyo.jpg"/></a>

Here is what I have today.
What is the delivery mean?
 

·
Registered
Joined
·
8,738 Posts
well, so your alarm siren is deaded (get one from Erie Vovo)

one of your struts is deaded (replace in pairs from Rock Auto)

Your rain sensor is maybe not dead, unless you replaced your windshield with aftermarket **** and didn't get the sensor installed correctly.
 

·
Registered
Joined
·
64 Posts
How old is your battery? Reason I ask is, when my car's battery was about to die, it threw a lot of codes... Mostly sensor faults, signal missing, etc. It even said my radio was missing! After replacing it with a new battery and cleared the codes, it all went away.
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #15 ·
well, so your alarm siren is deaded (get one from Erie Vovo)

one of your struts is deaded (replace in pairs from Rock Auto)

Your rain sensor is maybe not dead, unless you replaced your windshield with aftermarket **** and didn't get the sensor installed correctly.
Yeah I know siren battery is dead.
For strut I don't know if I should just rear both or 4 of them. Since the 2 front are replaced by previous at about 90k miles. And the rear 2 are leaking somehow. It's 128k miles now.
Rain sensor does not work so I unplug it.
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #16 ·
How old is your battery? Reason I ask is, when my car's battery was about to die, it threw a lot of codes... Mostly sensor faults, signal missing, etc. It even said my radio was missing! After replacing it with a new battery and cleared the codes, it all went away.
Battery is OK. But if I turn key to on no engine then it will say low battery. But start OK.
Thanks for the info. Will try if have chance.
 

·
Registered
Joined
·
2,621 Posts
Here is what I have today.
What is the delivery mean?
Delivery is the tab where you clear faults before you deliver the vehicle to the customer.

Judging by your suspension faults. you could have a faulty front strut. Have you performed a SUM calibration? I would try and clear faults and then perform a SUM calibration. You can do that under Vehicle Communication, SUM, Advanced and click on calibrate SUM.
 

·
Registered
Joined
·
64 Posts
Battery is OK. But if I turn key to on no engine then it will say low battery. But start OK.
Thanks for the info. Will try if have chance.
Mine starts okay too but when VIDA and dice is plugged in and pos II, reading on VIDA(upper right Corner) says 11.5v-11.10v...which is below specs. Check yours, and replace if needed. It shouldn't show the low battery warning while using VIDA/dice for a short time.
 
1 - 19 of 19 Posts
Top