SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
3,254 Posts
Discussion Starter · #1 ·
OK...so yesterday I get in my car and start it and the recirc and on/off button controls for the A/C start flashing orange and green for about 10 seconds. Then no fan blowing cold air. I switch it to auto and manual mode, recirc and regular and still nothing! All this with a new evaporator 2 weeks ago!<p>OK so I'm thinking the blower motor is out. I turn the car off and go get my hair cut. 45 minutes later come out and start the car (with my fingers crossed) and lo and behold it's blowing cold air again. No flashing orange and green lights on the controls. I start it again this a.m. and it's working fine. Should I be worried? What do you think happened?
 

·
Registered
Joined
·
7,737 Posts
Not if it keeps working...may be just a quirk...but maybe not. Post again if it acts up.
 

·
Registered
Joined
·
63,543 Posts
Re: Mysterious A/C fan problems (soledoc)

It will <B>NOT</B> get better.<br>This is <I>usually</I> an interior temp sensor.<br>After about 30 seconds they usually go away and normal A/C functions resume.<br>You can drive it this way for a while until they flash continously and do not stop.<br>Not too expensive a deal, part is usually about 80-90 bucks, plus 1/2 hour labor.<br>Like an ABS module, this starts slowly and just gets worse and more common with time until it finally quits
 

·
Registered
Joined
·
3,196 Posts
Any chance blowing out the sensor with compressed air will help? I do this every few weeks whenever I clean the inside of my car. I guess it can't hurt in this case and a can of compressed air is very cheap.
 

·
Registered
Joined
·
63,543 Posts
Re: (Big Will)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>Big Will</b> »</i></TD></TR><TR><TD CLASS="quote">Any chance blowing out the sensor with compressed air will help? I do this every few weeks whenever I clean the inside of my car. I guess it can't hurt in this case and a can of compressed air is very cheap.</TD></TR></TABLE><br>Nope.
 

·
Registered
Joined
·
3,254 Posts
Discussion Starter · #6 ·
Re: (JRL)

It did it again this a.m. I had to turn the car on/off about 3 times before the fan stayed on and blew air. Kind of frustrating...especially with my kid in the car and saying "come on daddy...let's go!"<p>Is this a dealer thing or would my newly found independent mechanic be fine?
 

·
Registered
Joined
·
63,543 Posts
Re: (soledoc)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>soledoc</b> »</i></TD></TR><TR><TD CLASS="quote">It did it again this a.m. I had to turn the car on/off about 3 times before the fan stayed on and blew air. Kind of frustrating...especially with my kid in the car and saying "come on daddy...let's go!"<p>Is this a dealer thing or would my newly found independent mechanic be fine?</TD></TR></TABLE><br>A 98 can be done by an indie.<br>You don't have to turn it on and off, it should just stop flashing in a minute or so<br><I>(It should)</I><br>Radio is is "in the mail"
 

·
Registered
Joined
·
3,254 Posts
Discussion Starter · #8 ·
Re: (JRL)

It didn't stop flashing after 30 seconds the other day. It seems to be when I turn the car on and off that it will stop doing it. <p>Thanks for the radio <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0"> <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0">
 

·
Registered
Joined
·
3,254 Posts
Discussion Starter · #9 ·
Re: (soledoc)

Did it again this weekend. Let it run for several minutes and it still didn't shut off. What seems to work...and I don't know if it's just luck or what...but if I rev the engine a lot when I restart the car it seems to be OK <IMG NAME="icon" SRC="http://www.vwvortex.com/zeroforum_graphics/screwy.gif" BORDER="0"> <IMG NAME="icon" SRC="http://www.vwvortex.com/zeroforum_graphics/screwy.gif" BORDER="0">
 

·
Registered
Joined
·
7 Posts
Re: Mysterious A/C fan problems (soledoc)

soledoc,<p>I just went through exactly the same thing you are experiencing. Dealer started off replacing fan motor relay and eventually fan motor itself.<p>Mine works great now.<p>But don't count out temperature sensor already mentioned here.<p>I would've done repairs myself, but car was at dealer for other stuff already.
 

·
Registered
Joined
·
3,254 Posts
Discussion Starter · #11 ·
Re: Mysterious A/C fan problems (bac_fan)

How much did that run you for the repair?
 

·
Registered
Joined
·
3,254 Posts
Discussion Starter · #13 ·
Re: Mysterious A/C fan problems (gdogg16)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>gdogg16</b> »</i></TD></TR><TR><TD CLASS="quote">jim is right, just thought I'd let you guys know! <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/tongue.gif" BORDER="0"> </TD></TR></TABLE><p>Right about what? I thought Jim was always right.....when it comes to volvos at least.
 

·
Premium Member
Joined
·
5,856 Posts
Re: Mysterious A/C fan problems (soledoc)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>soledoc</b> »</i></TD></TR><TR><TD CLASS="quote"><p>Right about what? I thought Jim was always right.....when it comes to volvos at least.</TD></TR></TABLE><br>HARDLY! LOL
 

·
Registered
Joined
·
7 Posts
Re: Mysterious A/C fan problems (soledoc)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>soledoc</b> »</i></TD></TR><TR><TD CLASS="quote">How much did that run you for the repair?</TD></TR></TABLE><p>Relay - $ 180<br>Fan motor - $ 325.
 

·
Registered
Joined
·
63,543 Posts
Re: Mysterious A/C fan problems (gdogg16)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>gdogg16</b> »</i></TD></TR><TR><TD CLASS="quote">jim is right, just thought I'd let you guys know! <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/tongue.gif" BORDER="0"> </TD></TR></TABLE><br>Aren't I<I> most</I> (not all, but <I>most</I>) of the time? <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/biggrin.gif" BORDER="0"> <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/biggrin.gif" BORDER="0"> <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/cool.gif" BORDER="0">
 

·
Registered
Joined
·
692 Posts
Re: Mysterious A/C fan problems (JRL)

I have the same issue with the flashing lights, but it hasn't affected the a/c performance. The system DOES make a crazy noise-- clunking and creaking from an area that I can only deduce is in the vents, I think is related to the blowing air, but not positive. Sounds like something is loose. Any ideas, or at least instructions on how to remove the center vents to take a look?<br>
 

·
Registered
Joined
·
3,254 Posts
Discussion Starter · #18 ·
Re: Mysterious A/C fan problems (bac_fan)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>bac_fan</b> »</i></TD></TR><TR><TD CLASS="quote">Relay - $ 180<br>Fan motor - $ 325.</TD></TR></TABLE><p>Did that include labor?
 

·
Registered
Joined
·
63,543 Posts
Re: Mysterious A/C fan problems (soledoc)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>soledoc</b> »</i></TD></TR><TR><TD CLASS="quote"><p>Did that include labor?</TD></TR></TABLE><br>I will almost guarantee you THAT is not your problem
 

·
Registered
Joined
·
3,254 Posts
Discussion Starter · #20 ·
Re: Mysterious A/C fan problems (JRL)

good...I hope it' just the sensor as you said.
 
1 - 20 of 22 Posts
Top