SwedeSpeed - Volvo Performance Forum banner
1 - 20 of 153 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter · #1 ·
Hey guys. my S70 R is doing a 0-60 time 2s slower than it should. i changed all the oils recently and there was barley any improvment. wat else might cause the problem?
 

·
Registered
Joined
·
7,737 Posts
Check for a loose intercooler hose, or is your turbo capoot?
 

·
Registered
Joined
·
63,543 Posts
Re: my S 70 R is doing 0-60 in 9.45s!!!!!!!!!! Problem suggestions!? (Ishtta)

Send it over here, I'll take it off your hands. You don't want that "slow" Volvo anymore <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/wink.gif" BORDER="0">
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #6 ·
Re: my S 70 R is doing 0-60 in 9.45s!!!!!!!!!! Problem suggestions!? (JRL)

YO JRL, where do u live? i do need a good mechanic to fix it for me, im dying. a merc e320 is kickin my ass. its not right! <IMG NAME="icon" SRC="http://www.vortexmediagroup.com/images/banghead.gif" BORDER="0"> <IMG NAME="icon" SRC="http://www.vortexmediagroup.com/images/banghead.gif" BORDER="0"> <br>my turbo is fine, i think. it still kicks in at around 4000rpm, and there is tthe normal hissssing sound when i take my foot off the accelerator!
 

·
Registered
Joined
·
63,543 Posts
Re: my S 70 R is doing 0-60 in 9.45s!!!!!!!!!! Problem suggestions!? (Ishtta)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>Ishtta</b> »</i></TD></TR><TR><TD CLASS="quote">YO JRL, where do u live? i do need a good mechanic to fix it for me, im dying. a merc e320 is kickin my ass. its not right! <IMG NAME="icon" SRC="http://www.vortexmediagroup.com/images/banghead.gif" BORDER="0"> <IMG NAME="icon" SRC="http://www.vortexmediagroup.com/images/banghead.gif" BORDER="0"> <br>my turbo is fine, i think. it still kicks in at around 4000rpm, and there is tthe <B>normal hissssing sound </B>when i take my foot off the accelerator! </TD></TR></TABLE><br>Nope.<br>Replace all your hoses, these do crack and leak. You're probably getting very litle boost.<br>Buy a hose kit (like a Samco) from one of the suppliers here and check all the other small vacuum lines
 

·
Registered
Joined
·
214 Posts
Re: my S 70 R is doing 0-60 in 9.45s!!!!!!!!!! Problem suggestions!? (JRL)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>JRL</b> »</i></TD></TR><TR><TD CLASS="quote"><br>Nope.<br>Replace all your hoses, these do crack and leak. You're probably getting very litle boost.<br>Buy a hose kit (like a Samco) from one of the suppliers here and check all the other small vacuum lines</TD></TR></TABLE><p>+1<p>When I replaced my turbo hoses with Samco's in March I found that my discharge hose on the top of the turbo had a dime sized hole in it. Needless to say the XC's performance was better after the replacement. Did a silicone vac hose replacment at the same time too. Performance feels almost like new.
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #10 ·
I searched for the SAMCO turbo hose kit, it costs like 240$ without shipping! but if that is wat my car needs ill do it. the dealer told me today that it might me the katalysor!? watever that is. im going to test it tommorow and see if there are any improvments. Thnx guys for your help!<br>btw, did any1 suffer fromsuch sever preformance decrease before????
 

·
Registered
Joined
·
63,543 Posts
Re: (Nebor)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>Nebor</b> »</i></TD></TR><TR><TD CLASS="quote">There's no way the catalytic convertor is causing that kind of performance problem.</TD></TR></TABLE><br>It sure can.<br>If the converter is clogged up the car will SLOW DOWN BIG TIME
 

·
Registered
Joined
·
235 Posts
Re: (GT854T5)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>GT854T5</b> »</i></TD></TR><TR><TD CLASS="quote">Exactly what clogs up a Cat. convertor???</TD></TR></TABLE><p>When the honeycomb inside it breaks down and mushes together, impeding flow. <p>The solution is to use a boost controller to increase the boost, and blow the broken honeycomb out the tailpipe.<p> <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0">
 

·
Registered
Joined
·
63,543 Posts
Re: (Nebor)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>Nebor</b> »</i></TD></TR><TR><TD CLASS="quote"><p>When the honeycomb inside it breaks down and mushes together, impeding flow. <p>The solution is to use a boost controller to increase the boost, and blow the broken honeycomb out the tailpipe.<p> <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0"> </TD></TR></TABLE><br>Yeah right!<br>Please, gimme a break <IMG NAME="icon" SRC="http://www.vwvortex.com/zeroforum_graphics/screwy.gif" BORDER="0">
 

·
Registered
Joined
·
235 Posts
Re: (JRL)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>JRL</b> »</i></TD></TR><TR><TD CLASS="quote"><br>Yeah right!<br>Please, gimme a break <IMG NAME="icon" SRC="http://www.vwvortex.com/zeroforum_graphics/screwy.gif" BORDER="0"> </TD></TR></TABLE><p>My point is, it's 10 times more likely that one of his boost hoses is leaking, since that's a known 850\s70 issue. The odds of the cat going out on a stock S70R just aren't nearly as high.
 

·
Registered
Joined
·
63,543 Posts
Re: (Nebor)

This is a moot conversation, we don't know how many miles are on his car.<br>A converter can be ruined by one very bad tank of gas, looking at where he lives this is a possibility.<br>The hoses are naturally are cheaper and a good place to start looking but if he has either one of these problems his car should be throwing a code
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #18 ·
Re: (JRL)

i\my car has done 62000km (38000 miles), not much. my dealer said that at that mileage its unlikely that a hose is leaking, but i told him to double check anyway. i get the car today, hope that its improved. im going to time its 0-60 again, anything below 8sec is an improvment. thnx again guys. btw, the cat converter does drain power, but i dnt think it will slow the car down that much! <br>ohh, and btw, the dealer said that if there is a leak in one of the turbo hoses the check engine light will turn on. is that correct???? <IMG NAME="icon" SRC="http://www.vwvortex.com/zeroforum_graphics/screwy.gif" BORDER="0">
 

·
Registered
Joined
·
7,737 Posts
A hose off will throw a code...ask me how I know.
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #20 ·
Re: (MadeInJapan)

How Do you know??? LOL<br>i got my car back, its worse than before!! <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/mad.gif" BORDER="0"> as the dealer claims, the hoses are ok <IMG NAME="icon" SRC="http://www.vwvortex.com/zeroforum_graphics/screwy.gif" BORDER="0">. if its not the hoses, nor the cat converter , wat else is there!! might it be that the engine busted? or the turbo is dead? i mean it only has 65000 km done!!! <IMG NAME="icon" SRC="http://www.vortexmediagroup.com/images/banghead.gif" BORDER="0"> anyway, im taking it to a mechanic tommorow to help me get to the root of the problem. buys, im goin crazy here, i mean its killin me. 240bhp can barley make it on an uphill mountain road!! thats not how it should be. PLZZ HELP, i dnt want to loose my car! <IMG NAME="icon" SRC="http://www.vortexmediagroup.com/images/banghead.gif" BORDER="0">
 
1 - 20 of 153 Posts
Top