SwedeSpeed - Volvo Performance Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hi guys,
Ok so I've just purchased my first Volvo it is the s40 on at 54 plate (jan 2005) I bought this as a spares repair car ,there are a few minor electrical faults with it . It is the 1.8 SE which I'm led to belive is the ford duratec engine . Body work it absolutely brilliant , engine runs sweet as a nut 110k fsh , clutch and box are great too . And it's proberbly the smoothest and tightest car I've drove , getting on to the problems now ...

The first job on my list is ,reading on the dash info that srs service and the airbag light is illuminated . I've bought a diagnostics tool to read the ecu with the ability to clear fault codes , I've read the Ecu which is reading communication error . I'm assuming this could be a dodgy connection but I'm unsure were to start any ideas

Heated seats are not showing any sign or life tbh I can live with out them it's not a big deal but if it could be a easy fix I'd be happy if you could help

Next on the list is when putting the key into the ignition radio powers up display show station and I get sound . After around 10-15 seconds it goes off as if I've switched it off ,and doesn't come back on unless I remove the key and do the same again . I've tried to put a cd in but I think it may already have one in and won't eject it , I've tried changing the module in the boot with a another still the same problem

Next on the list is the driver side 2 doors they will not lock with the fob nor the internal central locking button . So it's a case of pushing the the buttons down on each door , and using the fob to lock the rest and ideas? As this has become really annoying

Also my front fogs do not come on not show any signs of life , rear fogs and all other lights work fine .



Many thanks in advance I am looking forward to you replys thanks Ty
 

·
Registered
Joined
·
757 Posts
As you sasy "spares car," I assume you're pretty a committed DIY. I'd recommend you get and set up a DiCE / VIDA scanner. THere's a steep learning curve, but it will pay off, for the cost of a single dealer "we'll have a look" visit.

I assume you've checked the fuses. The radio shutdown does sound like a CD in the player acting up, offhand. VIDA would tell you for sure.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Hi thanks for the reply . I bought the car as faulty as the guy couldn't really sell it as fully working with the srs light illuminated . Since buying the car I have covered over 1200 miles and the car drives faultlessly .I have read the car with another obd2 scanner I have use of which is a autel maxi check . It is reading that there is a lost comication on the srs system this is the only fault displaying , would buying a vida dice scan tool give me more information thanks
 

·
Registered
Joined
·
757 Posts
The car I bought had a SRS fault. Dealer wanted $1700 for new DIM. VIDA showed it was a bad LED. YMMV, of course.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
Ah ok I've just ordered a vida diagnostic . I presume there pretty detailed on what they can read .I will let you know what the it says when it comes. Regarding the front fog lights . I whipped them out and checked the wiring . No power to either of the lights . I then resorted to going under the bonnet to the fuse . 15amp f29 checked with a digital fuse tester no power . I then went to the relay in the same board . I switched this with the horn relay as I know this relay works still nothing . I also checked each terminal with a multi meter on the relay socket no power to anything . Upon pressing the switch next to the petrol cap it is dead to the world and does not illuminate . Any ideas guys ?
 

·
Registered
Joined
·
757 Posts
I think you'll like the DiCE /VIDA setup. Another resource out there is a 200 page wiring diagram PDF.

A UK Volvo forum has a lot of discussion of cleaning CEM contacts, but I wouldn't go there unless I was sure the CEM was the source of the problem.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
What would you clean with just a electrical contact spray ? I could see this been the problem as the problems all come at once apparently
 
1 - 7 of 7 Posts
Top