SwedeSpeed - Volvo Performance Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1 (Edited)
This morning on the way to work, about 6 miles into my 15 mile commute, I heard a slight clunk from the rear end. I actually thought i ran over a stick at first. Then multiple dash lights illuminated including ABS, Brake and the message, "Brake System Failure, Stop Safely". I slowed to the next red light <1/4 mile from when all the lights popped up and the car stalled/died and would not restart. All the electronics were still working but the car would not start and i actually couldn't get it to completely turn off. Flat bed arrived, its been at the dealer for about 4 hours now and still haven't evaluated it :mad:. My car has ~ 8K miles. Any thoughts would be appreciated.
Thanks
 

·
Registered
Joined
·
16,851 Posts
Did you run something over ? That Break System Failure message is useless. I get that then a abs sensor goes bad.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
No, I definitely did not run anything over.
 

·
Registered
Joined
·
11,927 Posts
Pretty sure the error message had "Brake" in it instead of "Break"... :D
Did the brake pedal actually give you normal stopping power, or was it noticeably worse?

Anyway, it's under warranty, let the dealer figure it out. Enjoy beating on their loaner car in the meantime.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5 (Edited)
Haha...Thats what I get for angry typing and no proof reading! Will edit.
Agreed, though its like pulling teeth to get a loaner these days. They are "working on finding one" Ugh
I didn't notice a difference in stopping power, though i didn't try and stop with much force.
 

·
Registered
Joined
·
3,481 Posts
What's the word on this? I'll admit to being very curious as to what happened.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
Well, we are on day 3 with car at the dealer. Service Manager reports that they "got it running" but they still are not sure what the problem is/was. He tells me they have been on the phone with Volvo trying to diagnose the issue, but have not found the source of the problem. None of this sounds reassuring. Soooo, i'm waiting for the update today. I'll be sure to report on any updates.
 

·
Registered
Joined
·
238 Posts
I wouldnt trust that car now! I would make the dealer buy it back and you get a new one. Clearly there are serious issues if after 3 days they cant figure it out?!?!
 

·
Registered
Joined
·
11,927 Posts
The challenges of a new model and new company ownership. We are all keen to hear an update.
I don't think there have been any significant changes to the XC70 T6 AWD since 2011 other than the new dashboard with Sensus and some cosmetic stuff.
I doubt there have been any changes to the brakes/ABS since 2008.
 

·
Registered
Joined
·
48 Posts
I had some weird electrical gremlins in my '10 (3.2)... while nothing affecting the brakes, I got the traction control message, the fuel gauge was all over the place and on more than one occasion it just died. They replaced the fuel pump (twice) and a sensor or two, but what seems to have fixed it (no problems for past several months) was described to me as fixing the wiring from the fuel pump to the dash and ecu... I think they replaced some parts of the harness and re-seated some connections.

Good luck, I hope it gets straightened out for you.
 

·
Registered
Joined
·
288 Posts
I don't think there have been any significant changes to the XC70 T6 AWD since 2011 other than the new dashboard with Sensus and some cosmetic stuff.
I doubt there have been any changes to the brakes/ABS since 2008.
I think there might be quite a few changes behind the scenes. For example, I have a lot of Ford-branded parts in my 2012, and I suspect those are being transitioned to new bits here and there.

This is nothing against Geely, and not a promotion of Ford, but there could be some new issues to sort out.
 

·
Registered
Joined
·
11,927 Posts
I think there might be quite a few changes behind the scenes. For example, I have a lot of Ford-branded parts in my 2012, and I suspect those are being transitioned to new bits here and there.

This is nothing against Geely, and not a promotion of Ford, but there could be some new issues to sort out.
That is possible, but I really doubt that would happen all that much. Geely I'm sure has been focused on the SPA platform, rather than "porting" the P3 platform bit by bit. After all P3 = Ford EUCD platform. Ford still owns that platform.
You could certainly just check for different part numbers over the years though if there was something specific you're curious about.
 

·
Registered
Joined
·
3 Posts
Hey NYCxc70, so what was the problem with your T6? Did Volvo resolve your issue or compensate accordingly? Would love to hear, since I'm pretty much driving the same vehicle with black interior......Thanks
 

·
Registered
Joined
·
62 Posts
My C30 had almost the same problem and it ended up being a bad battery that was shorting out internally. They replaced the battery and all has been well ever since.
 
1 - 15 of 15 Posts
Top