SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
2,545 Posts
Discussion Starter · #1 ·
I'm not suggesting I have a problem here but I'm just curious as to why the CEL flashes 7 times when I put the key in the run position "II" with the engine NOT running (it start about 3 seconds after putting it in position II).<p>I can't find any reference to this anyhere (searched SS and the owners manual <A HREF="http://new.volvocars.com/ownersdocs/2006/2006_S60/06s60_00.htm" TARGET="_blank">http://new.volvocars.com/owner...0.htm</A>).<p>Anyonw know that this means and does it happen to your P2 <I>R</I>?<p>LTA<br>
 

·
Registered
Joined
·
63,543 Posts
Re: MIL / CEL / Engine light flashes 7 times? (LTA)

You're f**cked! <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/eek.gif" BORDER="0"> <br>(Your CEM may need a reaload)
 

·
Registered
Joined
·
2,545 Posts
Discussion Starter · #4 ·
Re: MIL / CEL / Engine light flashes 7 times? (JRL)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>JRL</b> »</i></TD></TR><TR><TD CLASS="quote">You're f**cked! <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/eek.gif" BORDER="0"> <br>(Your CEM may need a reaload)</TD></TR></TABLE><br>Okay, I'm ready to reload, I've got my laptop online with VCNA and VIDA connected to my OBD2 port via VCT2000 what do I do next?<p>Ha, ha, very funny JRL! I tought the f-word in its past-tense was 6 letters long, what's the extra letter for?<p>I'm sure the 7 flashes are normal, just wondering if there is any significance (and by the way, it happens after about 12 seconds, not 3 like I originally posted).<p>LTA<br><BR><BR>
<i>Modified by LTA at 10:42 PM 6-4-2006</i>
 

·
Registered
Joined
·
96 Posts
He sure got my attention! I Think I am getting a bit paranoid with my baby, um sorry, car... <br>So LTA / JRL, is this normal then?
 

·
Registered
Joined
·
63,543 Posts
Re: (acg69)

No, it's NOT normal.<br>As I said it may require a reload of the CEM (Central electrical module), the electrical guts of the engine.<br>Not that big a deal, I just had it done for something else but you will lose all the settings so remember to tell them what you had
 

·
Registered
Joined
·
63,543 Posts
Re: (acg69)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>acg69</b> »</i></TD></TR><TR><TD CLASS="quote">what kind of settings are we talking about?</TD></TR></TABLE><br>Aw gees (sigh)<br>Your seat heaters, your mirror, door locks, etc.
 

·
Registered
Joined
·
1,202 Posts
Re: MIL / CEL / Engine light flashes 7 times? (LTA)

Nope, that just means that the car isn't ready for emission testing. Nothing is wrong with your car.<p>Just drive it next 10 or so miles with constant speed to "warm-up" the emission process. Or you could be cruising for about 25 minutes with constant RPM.<p>As long as the CEL is not on with the engine ON, you're fine.<p>This happens to brand new cars, or newly reflashed/ reloaded ECM
 

·
Registered
Joined
·
2,545 Posts
Discussion Starter · #10 ·
Re: MIL / CEL / Engine light flashes 7 times? (djeremya)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>djeremya</b> »</i></TD></TR><TR><TD CLASS="quote">Nope, that just means that the car isn't ready for emission testing. Nothing is wrong with your car.<p>Just drive it next 10 or so miles with constant speed to "warm-up" the emission process. Or you could be cruising for about 25 minutes with constant RPM.<p>As long as the CEL is not on with the engine ON, you're fine.<p>This happens to brand new cars, or newly reflashed/ reloaded ECM</TD></TR></TABLE><p>My CEL is not on when the engine is running. I can't recall if it's always done it but I reset the ECU two weeks ago (pulled fuses 9 and 16). My memory seats seem to loose there memory now and then which might be related.<br>Your thoughts are different than JRL's, I'll have to ask my local volvo tech <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/eek.gif" BORDER="0"> <p>(I'm doing this from my Blackberry, sorry for the typos, etc)<p>LTA<br>
 

·
Registered
Joined
·
333 Posts
Re: (JRL)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>JRL</b> »</i></TD></TR><TR><TD CLASS="quote">No, it's NOT normal.<br>As I said it may require a reload of the CEM (Central electrical module), the electrical guts of the engine.<br>Not that big a deal, I just had it done for something else but you will lose all the settings so remember to tell them what you had</TD></TR></TABLE><p>Jim, is that the same as the engine management, or is CEM a just for "settings" ?
 

·
Registered
Joined
·
63,543 Posts
Re: (blf)

CEM reload doesn't touch the ECU or SUM settings
 

·
Registered
Joined
·
2,545 Posts
Discussion Starter · #13 ·
Re: (JRL)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>JRL</b> »</i></TD></TR><TR><TD CLASS="quote">CEM reload doesn't touch the ECU or SUM settings</TD></TR></TABLE><p>That's good to know since until now I was thinking they were one in the same.<p>There is a TNN that could be related for those with MY05&MY06:<br><A HREF="http://www.alldata.com/tsb/Volvo/1148281200000_1148626800000_TNN37-35/351.html" TARGET="_blank">http://www.alldata.com/tsb/Vol....html</A><p>I have to go check my chassis number...<p>LTA<br>
 

·
Registered
Joined
·
2,545 Posts
Discussion Starter · #14 ·
Re: (LTA)

Got my R back from the dealer today. They claim the CEL blinking 7 time while the engine if off and key in position III is normal. Claim was sustantiated this way "Checked another S60R to confirm operation is normal and it is' <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/rolleyes.gif" BORDER="0"> Not too convincing. That just tells me the other R they checked likely has the same problem. Other than my window heading back down after auto-up and truning off the engine all of the electronics seems fine (they also said the window thing is normal and verified it the same way).<p>Can any other 2006 S60R owners tell me if you experience this?<p>LTA<br>
 

·
Registered
Joined
·
2,545 Posts
Discussion Starter · #16 ·
Re: (JimLill)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>JimLill</b> »</i></TD></TR><TR><TD CLASS="quote">ECM = Engine Control Module (Engine "brain")<p>CEM = Central Electronics Module (Master "brain")</TD></TR></TABLE><p>and...<p>CEL = Check Engine Light (term used in Canada and most other countries)<p>MIL = Manfunction Indicator Lamp (term used in the USA but idential to CEL)<p> <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/sly.gif" BORDER="0"> But none of this answers my question: Does anyone else with a 2006 R (S or V) get the 7 flashes?<p>LTA<br>
 

·
Registered
Joined
·
234 Posts
Ok guys...ready for my analysis? When the Check Engine light is blinking at position II, it means that the car is still in drive cycle phase in order to set and/or calibrate engine/sensor parameters. This happens due to disconnecting the car's battery and CEM looses all stored parameters like (O2 sensors, evap sensor, catalytic, etc). I have seen this happen to my caR and after 3 good drives, the check engine light will no longer flash and will disappear after a few moments. If you actually connect an OBD2 reader during the drive cycle phase, it will tell you what sensors still need to be calibrated with driving (and if I recall correctly, there are 5 parameters that need to go through a complete drive cycle in order to set). So yea...thats what the blinking check engine light is indicating.
 

·
Registered
Joined
·
60 Posts
@LTA, I just got exactly same thing for my 2006 S60R, CEL blinks for 7 times then goes off with key in position II or III. Do you finally know what's happening or find way to fully resolve this?

Hope you still remember this thread as it was posted in 2006:)
 

·
Registered
Joined
·
3,313 Posts
apsyx,

read the post above, explains a bit... don't be too alarmed, just drive the car for a week normal without hard accelerations and such then check. If there are no CEL while the car is on and running, don't worry too much.

Where in Pgh are you? I have a house in Duquesne Heights, near Monteray Bay Fish Grotto (on Grandview). I'll be in the burg in a week or two.
 
1 - 20 of 21 Posts
Top