SwedeSpeed - Volvo Performance Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
252 Posts
Discussion Starter · #1 ·
my deal on my 04 V70...
Last Sunday i changed out my bad left drive shaft. and on Wednesday Anti -Skid message in dash, which i pulled the ECM fuse under hood to get home..Well today i got a Anti-Skid message again and after that a brake failure stop carefully. i think she is in limp mode and not down shifting all the way? tonight after she has sat a while i put my OBDII reader in and getting a p0600 code, and now getting a transmisson requires service message in dash. also last Sunday i did a oil change and tranny drain and fill....
now the brake failure message i do know my brake pads are really bad and i am hoping changeing out the brakes will clear that up. all the brake parts in the back just waiting to be put on. or i hit something changing out driveshaft????
any ideas guys.... thanks!
 

·
Registered
Joined
·
252 Posts
Discussion Starter · #3 · (Edited)
removed the drain nut on trans, pulled dip stick out and filled.

did the front brakes last night, new pads and rotors. not sure if its just the dust shield but i am getting high pitched sound when i make a left turn coming from the right side wheel? not sure if its the shield or maybe the caliper??
pulled fuse #23 and so far no codes.

so far so good! nice to have a smart car i guess, my front pads were almost paper thin time i got a chance to change them and the car was telling me..
168K and man i hope she keeps going!!!
 
1 - 3 of 3 Posts
Top