SwedeSpeed - Volvo Performance Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1,377 Posts
Discussion Starter · #1 ·
Hi everyone

Os I just got my car back for a PCV service and some other work. They did a great job but the next day I have a CEL for a P0128. Basicly my cars temp gauge lays flat and the car is trying to warm. Up. I cleared the code via torque pro but still having the same issue but no CEL yet.....I'm assuming it's the coolant temp sensor on the thermostat? It's going back tomorrow morning....

Sent from my SAMSUNG-SGH-I337 using Tapatalk
 

·
Registered
Joined
·
8,061 Posts

·
Registered
Joined
·
1,377 Posts
Discussion Starter · #3 ·
Yeah I was afriad of that. I never win with this car.....the snabb intake is nice tho....

Sent from my SAMSUNG-SGH-I337 using Tapatalk
 

·
Registered
Joined
·
1,377 Posts
Discussion Starter · #4 ·
Well its ok for now. They burped the system again and did a reset as it seems air was trapped in the thermostat. All I can say is torque pro is a sweet app!

Sent from my SAMSUNG-SGH-I337 using Tapatalk
 

·
Registered
Joined
·
1,377 Posts
Discussion Starter · #6 ·
It's a phone app that works with a obd2 Bluetooth reader

Sent from my SAMSUNG-SGH-I337 using Tapatalk
 

·
Registered
Joined
·
1,377 Posts
Discussion Starter · #7 ·
Well car was fine for a day. Drive to work and them I start losing the temp gauge and then heat. No CEL yet but I have a gray code for P0116 but no P0128 this time. Dropping the car off tonight before I leave for my honeymoon.....

Sent from my SAMSUNG-SGH-I337 using Tapatalk
 

·
Registered
Joined
·
13,991 Posts
Maybe just more air in the system that needs to be purged.

I agree on Torque Pro - a great tool for all of $5 plus the cost of the obd dongle.
 

·
Registered
Joined
·
1,377 Posts
Discussion Starter · #9 ·
Maybe just more air in the system that needs to be purged.

I agree on Torque Pro - a great tool for all of $5 plus the cost of the obd dongle.
They thought that to and it worked...for awhile. Car is in limp mode as well. Hard to tell with all the snow. I also noticed that when it was working it seemed the car too longer to get to temp

Sent from my SAMSUNG-SGH-I337 using Tapatalk
 
1 - 9 of 9 Posts
Top