SwedeSpeed - Volvo Performance Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 · (Edited)
Hey guys,

I just purchased a 07 R with 83k on it. On fast high RPM shifts the clutch gets stuck to the floor for about 1 second. Normal driving the car shifts fine.

From my research it appears to be the salve cylinder.....:mad: Is there any chance it could be the master cylinder? What are the symptoms of the master cylinder going bad?

I have no experience with dual mass. Is the "special clutch tool needed"?? (pictured on the left)


I have done clutches on a 850s and C70s and never used such a tool. It appears to me that this tool just presses the clutch evenly to the flywheel. The same result can be achieved by installing the clutch mounting screws progressively???

Also, what are the odds of reusing the flywheel? If it appears to be in good condition use it? Sorry im trying to be a cheap ass. Trying to spend as little $ as possible, after just buying the car....:mad:

Edit, oh and how long do you guys think I till it totally takes a crap on me? Its not leaking any fluids.

Thanks in advance for your input!
-Art
 

·
Registered
Joined
·
4,740 Posts
You can use the flywheel if it's in good shape.

The tool to the left of your hand is the compression tool for unspringing the clutch and making it possable to mount the screws.

I would guess if you had master cylinder problems, you'd be having brake problems as well.
 

·
Registered
Joined
·
2,418 Posts
I've got a similar issue after replacing my slave, except it only happens under VERY hard driving shifting very quickly, I think there's just a little air in the lines... I have to pull the clutch up with my foot when it happens..
 

·
Registered
Joined
·
3,306 Posts
you dont need that special tool unless you are re-mounting a used pressure plate.
 

·
Registered
Joined
·
89 Posts
I just replaced my clutch master cylinder over R&R (not very fun by the way). My symtoms were non-shiftability. When the car was running, the car wouldn't shift into any gear.. so the clutch wasn't releasing. Already swapped the transmission, the slave and the clutch line. Bled multiple times. So.. yeah I don't think its the master in your case... I hope that helps
 

·
Registered
Joined
·
1,522 Posts
I've got a similar issue after replacing my slave, except it only happens under VERY hard driving shifting very quickly, I think there's just a little air in the lines... I have to pull the clutch up with my foot when it happens..
I have roughly the same issue when driving hard, the clutch goes very light for a few minutes afterward. I did bleed the brakes and clutch with new fluid, there's no air in the line and it still happens. I'm thinking it's the slave pre-warning, but mine's been that way for a year, and I'm over 100k miles.
 
1 - 6 of 6 Posts
Top