SwedeSpeed - Volvo Performance Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2,257 Posts
Discussion Starter · #1 ·
Alright, I'm officially pissed off. My trip computer, turn signals, rain-sensing wipers and washers are intermittently not working. I just had my 7500 mile service and the dealer says they diagnosed it via VADIS and found two faults that were supposedly corrected by the appropriate upgrades, but it is now happening even more frequently than before. Sometimes they will come on after driving for a period of time, other times not at all. What the hell is going on here? Gremlins maybe? Please help! http://********************/smile/emthdown.gif
 

·
Registered
Joined
·
4,382 Posts
Re: Malfunctioning Electronics (darylkaiser30)

maybe something is loose in your steering column wiring?
 

·
Registered
Joined
·
972 Posts
Re: Malfunctioning Electronics (ss60)

Seems like it is and going to be a common problem with the S60s. My turn signals would blink wildly at certain times. I would need to tap it a little to get it back to normal.
 

·
Registered
Joined
·
2,257 Posts
Discussion Starter · #4 ·
Re: Malfunctioning Electronics (ss60)

Quote, originally posted by ss60 »
maybe something is loose in your steering column wiring?

My thoughts exactly. The service report noted that the tech removed the cowling and inspected for water damage, etc. Not sure if they checked for a loose relay or anything though. I don't like changing lanes using hand signals, so the better fix this asap. It's also hard to see through the crust of dead bugs that has built up on my windshield. Oh well, at least I'm still under warranty...
 
1 - 4 of 4 Posts
Top