SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
Two days ago I got my RICA stage 2 and installed it. I found there is a hesitation at 3k - 3.5k RPM's. I had new spark plugs I needed to install, I figured that would cure the hesitation. Found that it drove much better, with only a slight hestation now only happening at 3.1k RPM's. So driving on my way to work today I passed someone and immediately after it started to have a very high-pitched squeal or whitsle under any boost, still heading to work I started to notice that car feels bogged down at anywhere above 2k RPM's, aslong as I change gears at or before 2k RPM's it wont bog. Got to work and thought maybe the OTE pipe wasn't fastened on correctly but couldnt find any signs of that. And of course the car doesnt make that sound when idleing so I couldn't pinpoint where its coming from.

Any thoughts?
 

·
Moderator
Joined
·
6,436 Posts
def boost leak. See if the OTE clamp is in correctly (it's easy to put it on the wrong way - ask me how I know).

Also, see if any of the rubber hoses by the IC are not loose or cracked

Here's my video of my rubber hose comming off the OTE pipe at wot...
When I went to start the car, I forgot to connect the IC hose to the OTE pipe, so it popped off and the car died (you can see it in the video below towards the end 42nd second) ... scared me for a second. Then when i took my car for a test drive, I realized that my OTE turbo clamp wasn't fastened propertly and it hissed at WOT
 

·
Registered
Joined
·
3,815 Posts
def boost leak. See if the OTE clamp is in correctly (it's easy to put it on the wrong way - ask me how I know).

Also, see if any of the rubber hoses by the IC are not loose or cracked

Here's my video of my rubber hose comming off the OTE pipe at wot...
When I went to start the car, I forgot to connect the IC hose to the OTE pipe, so it popped off and the car died (you can see it in the video below towards the end 42nd second) ... scared me for a second. Then when i took my car for a test drive, I realized that my OTE turbo clamp wasn't fastened propertly and it hissed at WOT
You aren't supporting your engine anymore?
 

·
Registered
Joined
·
3,157 Posts
Two days ago I got my RICA stage 2 and installed it. I found there is a hesitation at 3k - 3.5k RPM's. I had new spark plugs I needed to install, I figured that would cure the hesitation. Found that it drove much better, with only a slight hestation now only happening at 3.1k RPM's. So driving on my way to work today I passed someone and immediately after it started to have a very high-pitched squeal or whitsle under any boost, still heading to work I started to notice that car feels bogged down at anywhere above 2k RPM's, aslong as I change gears at or before 2k RPM's it wont bog. Got to work and thought maybe the OTE pipe wasn't fastened on correctly but couldnt find any signs of that. And of course the car doesnt make that sound when idleing so I couldn't pinpoint where its coming from.

Any thoughts?
It sounds like you have a boost leak somewhere. However, that may or may not be the only cause of the hesitation issue that you're also experiencing.

With regard to the hesitation that you've experienced, did you have the stock volvo software updated (or checked whether you had the most recent version of the software already installed) before installing the RICA tune? The reason that I ask is that I had major problems when I first installed my RICA tune because the tune that RICA sent me was based on the original version of Volvo software that included a hesitation issue between 3-3.5k RPM. Volvo eventually released a software update the solved the problem. If your R still has the original software, the tune that RICA sent you may have the 3-3.5k RPM flaw built into it.

This may not be your issue, but it is something to check, because I ended up replacing plugs and coils before eventually discovering that the tune itself was the cause of all the problems.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #5
It sounds like you have a boost leak somewhere. However, that may or may not be the only cause of the hesitation issue that you're also experiencing.

With regard to the hesitation that you've experienced, did you have the stock volvo software updated (or checked whether you had the most recent version of the software already installed) before installing the RICA tune? The reason that I ask is that I had major problems when I first installed my RICA tune because the tune that RICA sent me was based on the original version of Volvo software that included a hesitation issue between 3-3.5k RPM. Volvo eventually released a software update the solved the problem. If your R still has the original software, the tune that RICA sent you may have the 3-3.5k RPM flaw built into it.

This may not be your issue, but it is something to check, because I ended up replacing plugs and coils before eventually discovering that the tune itself was the cause of all the problems.
Yeah, I had a full CAN upgrade before I installed the tune because I had read about that.

And both sides of the OTE pipe look like there connected correctly. Unfortunenatly I have no tools at work to make sure that there seated properly.
 

·
Registered
Joined
·
2,165 Posts
Does the high pitched whine / whistle sound like this...
 

·
Registered
Joined
·
2,165 Posts
Nope it's the turbo I promise, directly boost related, and I have smoked and pressure tested everything. It is one of the seals or journal bearings going out. It added hesitation and increased high RPM falloff when it started happening... Been going on for a little over a year now with no signs of getting much worse. :\
 

·
Registered
Joined
·
3,815 Posts
Nope it's the turbo I promise, directly boost related, and I have smoked and pressure tested everything. It is one of the seals or journal bearings going out. It added hesitation and increased high RPM falloff when it started happening... Been going on for a little over a year now with no signs of getting much worse. :\
I just read that you have stage 2. That may be the turbo hitting its max boost. Do you get any compression surges?
http://www.youtube.com/watch?v=nCj6Spwl1CU
 

·
Registered
Joined
·
49 Posts
Discussion Starter #12
I just read that you have stage 2. That may be the turbo hitting its max boost. Do you get any compression surges?
http://www.youtube.com/watch?v=nCj6Spwl1CU
I dont believe so, the sound immediately happens when boost is developed at arround 2k rpm's not WOT. Now that I think about it, I'm wondering if something is wrong with the DP.
 

·
Registered
Joined
·
2,165 Posts
No surging, it does still pull hard. I made no changes to the car. I was driving for about a month out of storage, started the R one night, started driving around and was hearing this whining sound. Shut the car off started it again drove it and still there so I just figured I would drive it until it showed more than just a symptom of failing off slightly more aggressively at the top end, slight hesitaion when building boost. But after making that sound for a little over a year the problem has not gotten much worse. A turbo upgrade / rebuild is in my future just depends on stock, modified stock or whatever I can get my hands on if it's ready when it finally let's go... Cough, cough (ipd)....
 

·
Registered
Joined
·
1,844 Posts
How soon after you replaced your plugs did this begin to happen?

Reason I ask is because to do the plugs one has to remove (and replace) the charge air pipe and I see that you have an 04 (as do I). If when replacing it (the charge pipe), you don't take your time you may damage the O ring on the CP. So, if that happened the problem would not be visible and even though you clamped it down well, the boost will be escaping right there like MOFO. Does it sound like a jet when boosting?

Why do I pose this possibility? Because it has happened to me :)

Hope you find the source of the problem. Cheers
 

·
Registered
Joined
·
49 Posts
Discussion Starter #16
How soon after you replaced your plugs did this begin to happen?

Reason I ask is because to do the plugs one has to remove (and replace) the charge air pipe and I see that you have an 04 (as do I). If when replacing it (the charge pipe), you don't take your time you may damage the O ring on the CP. So, if that happened the problem would not be visible and even though you clamped it down well, the boost will be escaping right there like MOFO. Does it sound like a jet when boosting?

Why do I pose this possibility? Because it has happened to me :)

Hope you find the source of the problem. Cheers
Yeah it sounds a very high whistle noise, and it happened this morning and I replaced the plugs last night. And now that I remember that o-ring did look like ****. I bet you thats what is is. Ill check it tonight. Thank you for the suggestion!
 

·
Registered
Joined
·
73 Posts
Sound to me, as I have unfortunately heard this noise myself, like a cracked turbine housing. Crack is between the turbine wheel opening and the wastgate.


In this case the sound will aproximate a siren; will rise in frequency with turbine speed (boost).
 

·
Registered
Joined
·
49 Posts
Discussion Starter #18
Sound to me, as I have unfortunately heard this noise myself, like a cracked turbine housing. Crack is between the turbine wheel opening and the wastgate.


In this case the sound will aproximate a siren; will rise in frequency with turbine speed (boost).
Well since I've posted yesterday the squeal or whistle has gone away and has become a whooshing sound and a CEL. So im pretty sure its that o-ring.
 

·
Registered
Joined
·
2,165 Posts
Sound to me, as I have unfortunately heard this noise myself, like a cracked turbine housing. Crack is between the turbine wheel opening and the wastgate.


In this case the sound will aproximate a siren; will rise in frequency with turbine speed (boost).
Sad, but I have been thinking something along those lines for a while... I need to figure out a fix...
 

·
Registered
Joined
·
3,157 Posts
Sound to me, as I have unfortunately heard this noise myself, like a cracked turbine housing. Crack is between the turbine wheel opening and the wastgate.


In this case the sound will aproximate a siren; will rise in frequency with turbine speed (boost).
led_aaRt_2,

Did you have a tune on your R? If so, from which tuner?

Cheers,

Jeff
 
1 - 20 of 20 Posts
Top