SwedeSpeed - Volvo Performance Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3,005 Posts
Discussion Starter · #1 ·
Well I knew it would not be perfect forever. With 324K on the clock and 240 of them with a full IPD tune, I am getting a load noise from the valve cover. Car runs but not sure what it could be. Any ideas ?
 

·
Registered
Joined
·
2,238 Posts
Tapping? Does it increase with engine RPM?

Could be a lifter going bad. Not exactly a death sentence for your motor. If you can do a timing belt, you can pop off the cam cover + cams and change the offending lifter... or just replace them all since it will be hard to track down the faulty culprit.

PS: What model car?
 

·
Registered
Joined
·
3,005 Posts
Discussion Starter · #3 · (Edited)
Yes it does and thank for the input.

2000 XC. Well since it will be open any suggestion on what replace while its open ?
 

·
Registered
Joined
·
2,461 Posts
Check your oil level first, low oil=noisy valve train
 

·
Registered
Joined
·
3,005 Posts
Discussion Starter · #6 ·
Last week when shuffling cars in the driveway I started the car up and the noise was gone. I was waiting till next month to have it towed in thinking the worst. Since the noise was gone I decided to dive it to the shop on Friday. Got the call a bit ago that and oil change ( always synthetic )and still no noise. The guess was a stuck lifter. So will let it go and fix a few other probs that you have with 324K

Replace rear hatch release to repair a non working license plate light

Replace revers switch on transmission to correct no working back up light

Replace broken simi function drivers seat adjustment panel and switches

Thanks for all the input and amazed at how hard this car has been driven ( 48 sates and 7 cross country road trips) and still id fun to drive. In Jan I will do the timing belt water pump ect
 
1 - 7 of 7 Posts
Top