SwedeSpeed - Volvo Performance Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
274 Posts
Discussion Starter · #1 · (Edited)
The column switch on my 2005 V50 just stopped working. It will not stay on the high beam position. The "click" is gone. I can get the beams to work by holding it back.

Has anyone else had this issue? What is the repair I am looking at? Is the switch repairable?

I have 115M on the car
 

·
Registered
Joined
·
274 Posts
Discussion Starter · #3 ·
Thanks, yes, in the correct position.
I'll try the Mathews site. If I post on the V70 I'll get flamed for putting V50 on there. The switches are quite different....at least on the one I have.
 

·
Registered
Joined
·
274 Posts
Discussion Starter · #4 ·
Well............problem solved. I had the car in for a timing belt last week. I had not driven it since. My wife picked it up from the shop. She has not admitted that she moved the light position switch to automatic but that was the problem.
In the automatic position the high beams would not stay on.

I called our local Volvo dealer (Best Volvo) and they pointed me in the right direction.
I suppose I should have known this but I did not. In the five years I have owned the car I have never touched the position switch.

Mystery solved and for the right price.....all I had to do is eat one small crow.
 

·
Registered
Joined
·
57 Posts
Thanks, yes, in the correct position.
I'll try the Mathews site. If I post on the V70 I'll get flamed for putting V50 on there. The switches are quite different....at least on the one I have.
Ah, sorry for the confusion. Your initial post said 2005 V70 so that's why I suggested that link. Glad you got your issue resolved.

-Rich
 
1 - 5 of 5 Posts
Top