SwedeSpeed - Volvo Performance Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
722 Posts
Discussion Starter · #1 ·
This is an interesting one, for a while my car's been making clicking sound when I make sharp turn in low speeds, <B>it only happens when I turn right</B>. It literally sounds like: "Click-Click-Click-Click-Click" or kind of similar when tire is throwing small rocks. There doesn't seems to be any clearance issues. Any ideas?<p>Best I got from dealer's mechanic was: "Worn rubber is making the sound" WTF! <IMG NAME="icon" SRC="http://www.vortexmediagroup.com/images/banghead.gif" BORDER="0"> - but at least Volvo Regional Tech took a look at it and is researching the problem - but who knows how long that will take. <BR><BR>
<i>Modified by JMn at 4:48 PM 6-28-2006</i>
 

·
Registered
Joined
·
722 Posts
Discussion Starter · #3 ·
Re: Left front Clicking sound (s60rdood)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>s60rdood</b> »</i></TD></TR><TR><TD CLASS="quote">Could be the common "axle ping" that just about everyone has.</TD></TR></TABLE><p>I actually had that way back and it was fixed, that was happening more when you were shifting gears from 1st to 2nd and accelerating/deaccelerating so this might be something new.
 

·
Registered
Joined
·
764 Posts
Re: Left front Clicking sound (JMn)

Hmmm, the car I WAS going to buy had the ping issue, but it only had it at very low speeds trying to manuver around the parking lot, and being very light on and off the throttle.
 

·
Registered
Joined
·
21,166 Posts
Re: Left front Clicking sound (s60rdood)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>s60rdood</b> »</i></TD></TR><TR><TD CLASS="quote">Hmmm, the car I WAS going to buy had the ping issue, but it only had it at very low speeds trying to manuver around the parking lot, and being very light on and off the throttle.</TD></TR></TABLE><p>Ping is fixable if the axle bolts are replaced with the updated ones from the XC90. Two loctites and new hubs didn't get rid of it but this has......so far.
 

·
Registered
Joined
·
1,052 Posts
Re: Left front Clicking sound (JMn)

Although it may have seemed to be fixed, it really does sound like the axle spline issue. Ask the service dept if they also replaced the seal between the two shafts. It took my dealer three attempts but this was what finally got the issue to go away (well for now, knock on wood).
 

·
Registered
Joined
·
2,124 Posts
Re: Left front Clicking sound (JMn)

The noise you describe is a classic sound of a failed stub axle u-joint. I assume these have been checked?
 

·
Registered
Joined
·
722 Posts
Discussion Starter · #8 ·
Re: Left front Clicking sound (rogersampson)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>rogersampson</b> »</i></TD></TR><TR><TD CLASS="quote">The noise you describe is a classic sound of a failed stub axle u-joint. I assume these have been checked?</TD></TR></TABLE><p>From what I've seen this far I would be suprised if they even took the wheel off. <IMG NAME="icon" SRC="http://********************/smile/emthdown.gif" BORDER="0">
 
1 - 8 of 8 Posts
Top