SwedeSpeed - Volvo Performance Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
I ran into old school analog electronic gremlins on my 2010 XC60 when I tried to 1) replace my incandescent brake lights with LEDs, and 2) connect an LED light system to my official Volvo trailer hitch and Volvo light connector.

The very nice brake light LEDs recommended elsewhere on this forum http://www.superbrightleds.com/moreinfo/tail-brake-turn/1156-led-bulb-single-intensity-45-smd-led-tower/526/ rewarded me with a "Check Stop Lamp" message. The lights worked, but the message appears every time the vehicle is started. I know I could probably fix this by installing resistors to fool the computer into thinking that the LEDs were not LEDs, but I just don't want to fool with that. I reinstalled the factory incandescent bulbs. PM me if you're interested in 2 very gently used 1156 equivalent LEDs.

The trailer light LED array created a problem called "hyperflashing", again caused by vehicle electronics that expect to see incandescent bulbs only. Volvo issued a TSB on this issue in 2011, and an upgraded trailer light module is now available. The FANTASTIC service department at Lehman Volvo in Mechanicsburg, PA has been very helpful to me in correcting this problem.

YMMV, but I wanted to alert others to these pitfalls.
 

·
Registered
Joined
·
92 Posts
Does anyone have the TSB# for the recall? My dealer wants to charge me $433 for a new wiring harness on this issue.

I ran into old school analog electronic gremlins on my 2010 XC60 when I tried to 1) replace my incandescent brake lights with LEDs, and 2) connect an LED light system to my official Volvo trailer hitch and Volvo light connector.

The very nice brake light LEDs recommended elsewhere on this forum http://www.superbrightleds.com/moreinfo/tail-brake-turn/1156-led-bulb-single-intensity-45-smd-led-tower/526/ rewarded me with a "Check Stop Lamp" message. The lights worked, but the message appears every time the vehicle is started. I know I could probably fix this by installing resistors to fool the computer into thinking that the LEDs were not LEDs, but I just don't want to fool with that. I reinstalled the factory incandescent bulbs. PM me if you're interested in 2 very gently used 1156 equivalent LEDs.

The trailer light LED array created a problem called "hyperflashing", again caused by vehicle electronics that expect to see incandescent bulbs only. Volvo issued a TSB on this issue in 2011, and an upgraded trailer light module is now available. The FANTASTIC service department at Lehman Volvo in Mechanicsburg, PA has been very helpful to me in correcting this problem.

YMMV, but I wanted to alert others to these pitfalls.
 
1 - 2 of 2 Posts
Top