SwedeSpeed - Volvo Performance Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
220 Posts
Discussion Starter · #1 ·
For the past few months I have encountered some lag. It think it's gotten worst lately. I'll be driving and let go of the gas to slow down and press on the pedal again to speed up but sometimes there's a 1 to 2 second delay before the car speeds up. This is especially dangerous when merging onto a freeway where the on ramp is also the off ramp. Only happens from a rolling stop. Never from a complete stop. I wonder if it's the transmission downshifting too slowly. I may try the reset by putting the car into offroad and driving it above 35mph.
 

·
Registered
Joined
·
1,527 Posts
I'll be driving and let go of the gas to slow down and press on the pedal again to speed up but sometimes there's a 1 to 2 second delay before the car speeds up. This is especially dangerous when merging onto a freeway where the on ramp is also the off ramp. Only happens from a rolling stop.
On that same area, does it still appear to lag if you set the driving mode to dynamic?
 

·
Registered
Joined
·
1,527 Posts
No lag when set to dynamic.
Then maybe it's just the s/w learning your gas throttle pattern in eco / comfort mode. On various automatic transmission vehicles I've driven recently (including my MY2018 T6), there are times when the transmission seem to decide to downshift later or not at all.

I suppose you can test the gear selector while on the other mode you're using; see if manually forcing a downshift takes care of the lag.
 

·
Registered
Joined
·
296 Posts
How long has it been since you’ve changed your upstream o2 sensor? As this plays a part in the drive train and shift points.


Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
309 Posts
For the past few months I have encountered some lag. It think it's gotten worst lately. I'll be driving and let go of the gas to slow down and press on the pedal again to speed up but sometimes there's a 1 to 2 second delay before the car speeds up. This is especially dangerous when merging onto a freeway where the on ramp is also the off ramp. Only happens from a rolling stop. Never from a complete stop. I wonder if it's the transmission downshifting too slowly. I may try the reset by putting the car into offroad and driving it above 35mph.
I *KNOW* Exactly what you mean - my 17' v90 T6(35k) does this - its gotten so bad I'm scared to make left turns when yielding to oncoming traffic because of the temperamental lag. My 17' XC90 T6 (40k) doesn't seem to do this.. Tried multiple TCM resets to relearn.. but it comes back. Dealership seems to be happy to diagnose/troubleshoot - but of course can't get it to do it when tech is in the car -
 

·
Registered
Joined
·
296 Posts
ECM is probably learning and relearning your shifting patterns. For example, I drive using the geartronic manumatic quite a bit and when I switch to automatic for a road trip the tranny will upshift and downshift at irregular times until the ECM “learns” how you are going to be driving the car.


Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
2 Posts
Has anybody experience similar throttle lag issue on their 2018 or 2019 XC90 T6: after slowing car from 60mph to ~10 to 20 mph, try to accelerate the car again and there is delayed response between "foot pressing the pedal to car accelerating at the expected pace? People usually report anywhere from 1 to 3 seconds delay which is sufficient to scare a driver.

Have been looking around for a few European brands and it seems most European car brands have similar throttle lag issue.
 
1 - 10 of 10 Posts
Top