SwedeSpeed - Volvo Performance Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Seems like I've seen posts on this before, but the K&N I just got from IPD does not have the adaptor to fit the filter to the intake. Kind of irritating that they would not take the 10 seconds to check this before shipping it and save negative customer feelings, and having to pay the shipping on sending out the adaptor separately.
 

·
Registered
Joined
·
7,962 Posts
Re: K&N missing adaptor hose (Evan70)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>Evan70</b> »</i></TD></TR><TR><TD CLASS="quote">Seems like I've seen posts on this before, but the K&N I just got from IPD does not have the adaptor to fit the filter to the intake. Kind of irritating that they would not take the 10 seconds to check this before shipping it and save negative customer feelings, and having to pay the shipping on sending out the adaptor separately.</TD></TR></TABLE><p>Call K&N<p>They'll probably mail you one out for free.<p>ITs really not IPD's fault. The quality control at K&N for these things has really been going down hill.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #4 ·
Re: K&N missing adaptor hose (Ladrouille)

Oh I know it's not really a big deal, just seems like they'd want to avoid the little bit of dissapointment that the customer gets. Here I am all ready to put in the K&N, and there's no hose. Oh the horror, I have to put the stock filter back in. <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/tongue.gif" BORDER="0">
 

·
Registered
Joined
·
2,424 Posts
Same thing happened with mine. Call K&N, complain to them, but whatever you do, do NOT tell them it's the filter for a S60R/V70R. It'll start a 30 minute argument. Trust me, I've been there <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/rolleyes.gif" BORDER="0">
 

·
Registered
Joined
·
7,962 Posts
Re: (m3nt0s)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>m3nt0s</b> »</i></TD></TR><TR><TD CLASS="quote">Same thing happened with mine. Call K&N, complain to them, but whatever you do, do NOT tell them it's the filter for a S60R/V70R. It'll start a 30 minute argument. Trust me, I've been there <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/rolleyes.gif" BORDER="0"></TD></TR></TABLE><p>I wanna hear this story...hahah
 

·
Registered
Joined
·
237 Posts
I picked one up at a Advanced Auto and it was missing the Adaptor Hose too. Plus it came direct from K&N, Advanced did not stock them in their warehouses.<p>K&N Sent a new whole filter and hose for free, so I have a spare Filter now.<p>EDIT: m3nt0s I must of called after you because they did not even question the car. Thanks for clearing it up with them.. <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/tongue.gif" BORDER="0">
 

·
Registered
Joined
·
2,014 Posts
Re: K&N missing adaptor hose (chinaonnitrous1)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>chinaonnitrous1</b> »</i></TD></TR><TR><TD CLASS="quote"><p>Call K&N<p>They'll probably mail you one out for free.<p>ITs really not IPD's fault. The quality control at K&N for these things has really been going down hill.</TD></TR></TABLE><p>bought mine from ebay and same thing. <p>K&N sent one out no charge.
 
1 - 8 of 8 Posts
Top