SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 33 Posts

·
Registered
Joined
·
1,498 Posts
Discussion Starter · #1 · (Edited)
been trying to tune my build and something is wrong with the tcv/wastegate setup.

if i run the vacuum line from wastegate to turbo compressor it runs fine. boost to 18psi and holds perfectly.

soon as i plumb in the tcv it doesnt want to work. it will build boost until the turbo maxes out. ive hit 35 psi a couple times by accident already.

i have checked all my vacuum lines connections and there are no leaks. i am running the viva hd tcv too.

any ideas?

Edit: I have the vacuum lines ran same as if it were an internal wastegate.
 

·
Registered
Joined
·
2,586 Posts
apparently stock tcv is the way to go..


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,587 Posts
I'm curious if somebody has actually tuned the ECU for new turbo and tighter wastegate?
 

·
Registered
Joined
·
1,587 Posts
So why dont you contact him and sort it out together? I cant belive the car is tuned and no further adjustments needed...
 

·
Registered
Joined
·
8,055 Posts
You must have it hooked up wrong if its overboosting, with the solenoid unpowered it will port manifold pressure right to the wastegate. Only when energised will it block the port to the WG.
 

·
Registered
Joined
·
2,045 Posts


From my electronic gismo- Galaxy S6
 

·
Registered
Joined
·
2,045 Posts
Lol. Beat me by a split second. Google search is a great tool my friend.

From my electronic gismo- Galaxy S6
 

·
Registered
Joined
·
99 Posts
i think our wastegate use boost pressure for regulating the waste gate where most other manufactures use vacuum like bmw. is your aftermarket one actuated by boost or vacuum??
 

·
Registered
Joined
·
1,399 Posts
Try another TCV would be my first step. I'm running a stock one and it works perfect.




**Also make sure you have vac lines with a 1/4" ID as per the Tial website.



What waste gate spring(s) do you have installed? If you set the TCV duty cycle to 0, you should be able to run waste gate spring pressure to red line. Edit: re-read you post. Sounds like 18 psi spring and it holds to redline. So I would swap to a stock TCV
 

·
Registered
Joined
·
1,399 Posts
No, you should use one bottom port, plug the other two bottom ports and leave the top port open.
 
1 - 20 of 33 Posts
Top