SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter · #1 · (Edited)
OK... So here goes.
Last friday, 5/25/12 all is great, driving home from work car is normal.
I park it in Chicago for the weekend and use public transportation and my feet to get around, its cheaper than parking downtown.
Anyways, Monday afternoon I get in the car to head back to the burbs and the problems start:

1) Fuel gauge doesn't read that I have any gas.
2) Trunk wont open with the remote.
3) Rear doors wont unlock, cant open them. From inside either.
4) The Antiskid warning is displayed on the car, and the DSTC function doesn't work.

Has this happened to anyone before?
Should I start to panic?
This is my 4th month owning the car :(

For what its worth, 04 R 6MT 113k miles


ANY HELP is GREATLY APPRECIATED!
- Michael
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #12 ·
I see. There is a space under the hood where it look like a battery might go... for the s60 ?
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #15 ·

·
Registered
Joined
·
11,628 Posts
If you do go with a new bat I'd suggest OEM or Interstate. They are the same but depending on your area one could be a lot cheaper than the other.
 

·
Registered
Joined
·
233 Posts
Look in your owners manual in the back there is a list of what fuses do what. Sounds like a few of thoes item could be on the same fuse. I'd start by looking there first. Fuses are much cheaper than a battery.

Could be a loose connector of your rear electronic module. aka rem.

In case you did not know, there are 3 fuse boxes that I know of in the car.
 

·
Registered
Joined
·
1,882 Posts
OK... So here goes.
Last friday, 5/25/12 all is great, driving home from work car is normal.
I park it in Chicago for the weekend and use public transportation and my feet to get around, its cheaper than parking downtown.
Anyways, Monday afternoon I get in the car to head back to the burbs and the problems start:

1) Fuel gauge doesn't read that I have any gas.
2) Trunk wont open with the remote.
3) Rear doors wont unlock, cant open them. From inside either.
4) The Antiskid warning is displayed on the car, and the DSTC function doesn't work.

Has this happened to anyone before?
Should I start to panic?
This is my 4th month owning the car :(

For what its worth, 04 R 6MT 113k miles


ANY HELP is GREATLY APPRECIATED!
- Michael
Your REM fried itself. Easy fix but $$$$
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #19 ·
It can't be fried, the guage works if I take a sharp turn, almost like a loose connection or something.
Same w the trunk, doors, and antiskid.
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #20 ·
Easiest fix ever.. There are 2 power cables connected to the positive terminal on the battery. One broke off.
1.19$ fix :)
Thanks guys for the help!!
 
1 - 20 of 21 Posts
Top