SwedeSpeed - Volvo Performance Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
I am have a problem fitting the lower end (radiator end) of the ipd boost toob kit. It won't fit on to the tube that goes over the engine mount. Please help!!
Sent from my Lumia 900 using Board Express
 

·
Registered
Joined
·
4,017 Posts
If it doest fit, it doest fit, take some pics and talk to ipd guys, they will take care of you
 

·
Registered
Joined
·
146 Posts
Mine was a tight fit on the charge pipe side at the Intercooler connection, it does fit though. What year and model do you have?
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #4 ·
I have a 2001 s60 2.4t
But I will take some pics and send them to ipd an a post on here!
Sent from my Lumia 900 using Board Express
 

·
Registered
Joined
·
773 Posts
I got one of the earlier sets that came out, and after I had a terrible time installing, Lucky admitted that the first sets were very tight, and the later ones are still a bit tight. He suggested using soap (bar or liquid) to coat the inside of the hose, and then it will be easier to push on, but the clamp will still hold it.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #6 ·
I FINALLY got it on, took me awhile but with a little elbow grease (not literally) and got it to fit In there. (That's what she said)
Sent from my Lumia 900 using Board Express
 

·
Registered
Joined
·
517 Posts
The fit on those things is awful. If I could put the old one on back I would, except that I slyly cut it off thinking the ipd unit was of good quality and would fit good. It took me a good half hour and cost me a slew of cuts and bruises, trying to get that bitch on. And every time I have to do something around that area, it's always the same old story. A PITA to get back on. I actually had to get some some sandpaper and shave it down, and then shave the OTE pipe down as well! There goes the warranty! Woe am I! Nothing was wrong with the old one. Seriously, the fit on those things is trash. Or at least the first ones. I should have saved the money for some beer or something.

I shoulda done a boost leak test for goodness sake, instead of throwing money on parts and crap.
 
1 - 7 of 7 Posts
Top