SwedeSpeed - Volvo Performance Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
495 Posts
Discussion Starter · #1 ·
Please help,
Here's the deal my wife's 99 S70 will not start at the oddest times. We will get in the car after seeing a movie or going to the store (maybe an hour) turn the key and it will just click I have check the battery voltage and it is about 8 volts, we jump it and it is charging normal I don't know much about the starters on these, if the battery is low will they not crank over and just click? Or will do the normal slow crank and then die? Since it is intermittent it's hard to diagnosis. I don't know if I have a week battery issue each starter issue, or a power draw issue. ANY help is greatly appreciated! Has anyone else had this type of thing happen before? Or am I just lucky that way?
 

·
Registered
Joined
·
808 Posts
How old is your battery? Are you sure the alternator is ok? Make sure you check your battery cables and pay particular attention to the positive ones. The cable going from your batt to starter tends to corrode inside the connector where it attaches to the battery. There is also one that runs from the alternator. Also the B Positive cable is usually an issue on these cars, this is the 4 wired one that runs from your positive battery connection to a relay/fuse box towards the right rear of your engine compartment, and usually corrodes/ burns where it is bolted to it. If the battery and alternator check ok, then you are probably at the point where you need to replace your cables.
 

·
Registered
Joined
·
63,543 Posts
Battery
But more likely it's the antenna ring going bad
 

·
Registered
Joined
·
2,887 Posts
You sure, Jim? OP states that it just clicks.
AFAIK, lack of a coded key ( or bad antenna ring )
leads to the fuel system being cut, not the starter
cutout being activated.

This sounds a lot more like a charging system issue.
I agree that the battery, cables and connections are
the most logical place to start. Search "Voltage Drop".
 

·
Administrator
Joined
·
55,918 Posts
JRL-

The antenna ring? please tell me more....
This is what the antenna ring looks like: P/N:9442961 ( about $40 )



My XC since about 50k miles (at 115k now) has had 4 of these based on the previous owner's service records. My starting issue returned yesterday for the first time since I replaced my antenna ring a few hundred miles ago. I am wondering why the antenna rings failed, appears to be failing so soon or if there is another issue at play. Is it something with my key? My symptoms are when turning the key and it just keeps cranking, like its not getting fuel. I slammed my hand on the antenna ring and on the next turn it started, maybe coincidence, maybe not. I am going to keep an eye on this to see if the starting issue becomes more frequent again. I have replaced the battery.
 

·
Registered
Joined
·
2,887 Posts
A shot of contact cleaner in the connection,
followed by reseating the connector 8 or 10
times may help.
Get the cleaner in there and be sure the
contacts all get some good, repeated wipes.
 

·
Registered
Joined
·
378 Posts
8V at the battery is the problem. I would be looking for why. Bad battery, alternator, or cable. Maybe a draw somewhere, but less likely.
 
1 - 8 of 8 Posts
Top