SwedeSpeed - Volvo Performance Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 ·
1992 240 Automatic engine will start out fine. After awhile (10 minutes or so) the car looses power, sputters and will run very rough. Eventually the engine may even itself out. Most of the time it takes stopping the car turning off the engine and letting it sit for awhile. When the car is restarted, giving it very little gas at acceleration seems to help, almost as if it needs to catch up. Repeat process until I eventually reach my destination. Fuel filter replaced. Air filter replaced. Mass Airflow Sensor cleaned (no codes). Spark Plugs and wires recently replaced. Recently ran fuel injector cleaner through it.

Any ideas???
 

·
Registered
Joined
·
46 Posts
I suspect a similar issue affects your fuel control. See my answer here. http://forums.swedespeed.com/showth...nning-out-of-ideas!-I-love-my-240-Please-HELP!! Other corrosion issues at all sensors may be an issue also even if they are not indicating an error. The throttle position sensor on the back of the throttle shaft may cause fuel control issues. If you can measure fuel pressure that may be an issue. The fuel pressure regulator may be off, so injectors are not getting enough supply. Fuel pump relay is said to be an issue. Some folks cary a spare, just in case. Hope one of these helps.
 

·
Registered
Joined
·
538 Posts
Fuel pressure regulator or Mass Air Flow Sensor (MAF)
 

·
Registered
Joined
·
538 Posts
Even though you ran fuel injector cleaner, it may be the one of the fuel injectors is bad.
 
1 - 5 of 5 Posts
Top