SwedeSpeed - Volvo Performance Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
My '01 v70 T5 only misfires in stop and go traffic - if I am out on the open road it runs fine, but the CEL is pretty much constant. There are times when its not on, but they seem to be getting fewer and far between. I borrowed an Actron Autoscanner and got the following codes:

P1171 No DTC (no detectable code) , but some folks on the forums indicate that the MAF needs to be cleaned or replaced.

P0204 Injector cyliner open, Open cylinder 4

P0300 Random multiple misfire detected

P0354 Ignition coil D primary/secondary circuit malfunction

Before I got all the code detail, I had eliminated the possibility that this is a coil pack or spark plug at the no. 4 cylinder. I have checked the wiring for breaks as far as I am able without tearing apart more looms than have just crumbled away on their own.

Tomorrow I intend to get some MAF cleaner and attack that problem. Then I guess I need to check the no 4 injector - is there an easy way to do that? I'm not sure if the presence of some codes or combination of codes will in turn automatically throw a 3rd or 4th code. The P0300 and that fact that the car appears to run fine out on the open road has be baffled, and there doesn't seem to be any concrete info on it.
 

·
Registered
Joined
·
1,320 Posts
Please don't tell me you are running a K&N air filter (oil fouling of the MAF is not uncommon).

regards,

P
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
Nope, been there with an old 4Runner. More problems caused than anything gained.
 

·
Registered
Joined
·
252 Posts
maybe #4 coil went bad inside it you can't see that...
But if you can't get it, i have taken my V70 to Ed Colby's, there down the road from Annapolis VW on Hudson St.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
The 1171 code was cleared by cleaning the MAF. For the other three, it turns out it was the no 4 fuel injector that had gone bad. Even though they all sounded the same through a stethoscope, I replaced it with a rebuilt one off ebay (GB REMAN 852-12166, but also had the matching oem pn stamped on it) for about $30.00 with core charge. That cured the issue, the car now runs great, codes cleared and have not returned and the CEL is finally off.

I'll keep your recommendation of Ed Colby in mind though if needed.

Thanks!
 

·
Registered
Joined
·
23 Posts
I'm having the exact same issue currently.
01 V70 T5

Misfire on #2. (thats all the O'Reilly scanner would say. other scanners will tell you "Fuel Injector open")

New plugs, New Coils..

Still came back as misfire on 2.
Yesterday I pulled the Injectors, looked fine. Then switched 3/2.

Now i have a misfire in #3.

$40 shipped JY injector on the way. :facepalm:

Have you noticed a slight knocking sound after the new injector? ( you have to listen close)
 
1 - 7 of 7 Posts
Top