SwedeSpeed - Volvo Performance Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
Hi all...I have an 07 V8 xc90...when I have the stereo set on Aux with no cord plugged into the jack, I hear some weird squealing/ interference noise. When I plug the wire (3.5mm?) in, then I still hear it somewhat through whatever device is connected. I have changed the aux cord a couple of times...no luck. If I wiggle it a little, it sometimes goes away. Any ideas?
 

·
Registered
Joined
·
2,026 Posts
are your devices always charging when this happens? have you tried just plugging it in without the power connected?
 

·
Registered
Joined
·
2,026 Posts
Sounds like your plug is worn out. Mine was replaced early also (2008). The contacts inside are not making full contact with the 3.5mm plug, specifically the ground. so where you are getting some contact, it's not a good contact leaving a ground loop open allowing interference. you will always get a little noise when the player is being charged through the 12v charger because the grounds take different paths and allowing additional interference.
 

·
Registered
Joined
·
416 Posts
My 07 V8 has exhibited this condition since new. I was told that it's normal and have just lived with it. It only happens when there's no device connected so it didn't bother me too much.
 

·
Moderator
Joined
·
3,391 Posts
I believe it is fairly normal if there is no device plugged into it. If it occurs with a device connected, then the port is worn out. These ports do wear out quickly and easily. The plastic around the outside cracks and causes the plug to move around and lose connection with the contacts. It's very easy to replace, but be advised that the port is different depending on whether or not you have RSE.
 

·
Registered
2004 S60R M66 AWD and 2008 Volvo XC90 V8 AWD - Climate Pkg, Versatility Pkg, and Convenience Pkg
Joined
·
763 Posts
Anyone know if this is a ground loop?! It sounds like mechanical clicking coming from the glove box (empty). Would dearly like to get rid of it...
Link doesn't work...
 

·
Registered
Joined
·
1,083 Posts
Ground loops in audio systems cause noise through the speakers. As far as I know, there are no speakers inside the glove box...
 

·
Registered
Joined
·
699 Posts
We also have an 07 V8

Mine caused noise like the OP noted when the jack was worn. If I moved the aux cord plug into the jack, I could get it to go away (but had to hold it in position).

After changing the part (jack) in the XC90 console it went away.
 

·
Premium Member
2007 Volvo XC90 V8 Sport
Joined
·
8 Posts
Yes I also have a 07 V8 Sport and have noise as well. My new AUX jack is due in the mail today. After years of dirt, liquid, etc the connection gets sporadic. A new one will do the trick.
 

·
Registered
2008 XC90 3.2
Joined
·
1,364 Posts
Please update us if that fixes your issue. I too get intermittent light fuzz/static.
 

·
Registered
Joined
·
14 Posts
I totally disconnected the aux socket by separating the loom at the connector (in the armrest) and the noise was totally unchanged. It's odd. I would have thought the noise would be overlaid on the RSE audio that my kids hear in their wireless headphones but clearly it isn't as I would jolly well get nagged about it if it was.
So that means it's being introduced AFTER the infrared transmitter...?
My best guess at the moment is the automatic switch which detects whether something is plugged into the AUX socket and directs audio on that basis has gone bad but I don't know where that is.
 
1 - 16 of 16 Posts
Top