SwedeSpeed - Volvo Performance Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
519 Posts
Discussion Starter · #1 ·
Hey everyone:<p>This will be the first in a series of posts today. Thsi is for the installation of an Optima battery. As some of you may know I was having trouble with the OEM terminals clearing the battery. So, gone are the OEM's. I have installed Monster cable terminals and everything is working great.<p>I also fabricated my own battery tie down. I dremeled a large washer down to fit the ridges in the battery and then installed a large bolt through the battery tray. The washer was then put over the battery and the nut was tightened. It ain't pretty but it is small, out of the way, and does the job.<p>Battery<br><IMG SRC="http://www.stickypix.com/data/6070/931_289-med.jpg" BORDER="0"><p>Battery tie-down<br><IMG SRC="http://www.stickypix.com/data/6070/931_290-med.jpg" BORDER="0"><p>Thanks to Charles and Ron for their help.
 

·
Registered
Joined
·
6,564 Posts
Re: Installed Optima battery (larryo108)

Well, I hope you gonna have better luck with your Optima. Mine kept on having some leakage problem....meaning the battery is always dying if I don't drive the car in 2 weeks. Always have to hook the battery tender type of thing to it, or it will just drain itself out. <p>Maybe it could have been something else that I just can't find the source of power drain.
 

·
Premium Member
Joined
·
3,357 Posts
Re: Installed Optima battery (The_one_n_only)

The install looks good Larry!<p>You know, I've noticed some sort of leaking issue with mine but I think it's something else (like my underdrive pulley). When it starts snowing out, my battery drains itself rather quickly and my alternator doesn't put a charge though. Yes it only happens when it is snowing out. <p>When it's just cold out she has a tough time getting started but the alternator puts out enough volts to charge it. <p>Either situation will happen when I leave the car at work (or overnight) or going into a store. I need to talk with my audio shop but haven't had the time to do it yet. Only had to jump my car once so far. <p>RJ
 

·
Registered
Joined
·
7 Posts
Re: Installed Optima battery (The_one_n_only)

Hey one_n_only, don't feel alone, after the 2nd Optima leaking, I got a refund.... Dlr. said he had never seen that before.... Tom
 

·
Registered
Joined
·
6,564 Posts
Re: Installed Optima battery (Mechanic)

Interesting....how did you go about getting the refund? Who's Dlr?<p>Wow, I seriously thought I was the only one that had this happened to me. I know colder weather will play some role in this, but shouldn't be that bad. I have left my car in the storage before with just Interstate battery, never had a problem firing it up after 1 month or so.<p>Thanks for the info, I'm sure there are others out there who have the same problems.
 

·
Registered
Joined
·
7 Posts
Re: Installed Optima battery (The_one_n_only)

I went back to the place where I bought it (an alternator / starter rebuilding business) and showed them that it was leaking and said that that was the main reason I bought it ... I was tired of leaking batterys. No problem, here is a new one... month later, it too is leaking. The guy said to me, "want your money back?" That was 4-5 yrs. ago, I thought that they had probably fixed the problem by now.... Tom
 
1 - 6 of 6 Posts
Top