SwedeSpeed - Volvo Performance Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
I installed a new head unit in my '04 V70R yesterday and everything worked fine except I was getting engine whine through the speakers. Pulled it back out today to make some adjustments after researching issues with the factory amp adapter cable. I hooked the battery back up to test it out and noticed I had an SRS Service Urgent warning on the dash that wasn't there before. The only thing that was different from yesterday is I forgot to plug the AC unit back in before hooking the battery back up. Could that have tripped the warning or is there something else in that area that I could have hit? I didn't unplug anything else.
Thanks
 

·
Registered
Joined
·
144 Posts
The climate tripped the message. Just plug it back in and clear the code

Sent from my SM-G955U1 using Tapatalk
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #3 ·
Thanks, I was hoping that's what it was. Can I clear it by unplugging the battery again or does it need to be done with a reader and software?

The climate tripped the message. Just plug it back in and clear the code

Sent from my SM-G955U1 using Tapatalk
 

·
Registered
Joined
·
3,424 Posts
Always disconnect the battery before disconnecting the CCM. I think you need VIDA to clear it.
 

·
Registered
Joined
·
72 Posts
I made the mistake of unplugging my CCM to change a bulb, and now the warning won't clear on the console. It doesn't show up on vida, only on the dash...
 

·
Registered
Joined
·
144 Posts
I made the mistake of unplugging my CCM to change a bulb, and now the warning won't clear on the console. It doesn't show up on vida, only on the dash...
You probably have a faulty cluster. It's a known issue

Sent from my SM-G955U1 using Tapatalk
 

·
Registered
Joined
·
183 Posts
had same problem when I pulled radio out of S80 when I owned one. Only way to clear is with a tool such as vida. Removing battery etc is no help.
 

·
Registered
Joined
·
7,612 Posts
This is from memory so it may not be 100% right, but: It won't show an active code in vida once it's plugged back in, but on the clear codes page there's an additional box that says clear SRS. You want to click that.
 
1 - 9 of 9 Posts
Top