SwedeSpeed - Volvo Performance Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Car: 2007 Volvo S60 2.5t 56,000 miles (car in the Phoenix AZ area)

Symptoms: When cold car will start and die 25% of time, will restart and idle is often a little rough until warm, as car warms up will 'buck / surge' a little as it goes down road. This is especially noticeable in first 3-5 miles of driving, surging on light load on Freeway (60 mph) is especially noticeable. At high RPMs there are minimal symptoms. On hot restart symptoms get worse, stalling at stop lights (sometimes) and rough/weak acceleration up to about 40 mph then okay. When acting up seems to stutter over large bumps in road. No check engine light/code present (had local mechanic take a look, couldn't see anything in computer, and said bring it back when it gets worse - not a great answer)

Other odd symptoms: Car runs perfect (no surging) with MAF unplugged (mpg does decrease, and MAF code is set). MAF was replaced without change in symptoms, no problems with bumps or related with MAF unplugged.

Parts I've replaced (in effort to cure):
- Fuel pressure sensor (on rail)
- MAF
- Spark plugs
- Intake boots (now nice silicone ones)
- Coolant Temp Sensor
- All intake clamps retightened and inspected, all vac lines that I can see, seem okay
- Fuel filter
- Front O2 sensor
- TB cleaned
- Intercooler replaced

I welcome any ideas of what you'd look at.

Take Care,
Scott Daggert
 

·
Registered
Joined
·
4,017 Posts
try to check the fuel pressure if is enough on cold starts. Seems that something is wrong around that. Fuel pump?.
 

·
Registered
Joined
·
339 Posts
did you replace the MAF with OEM part or aftermarket?

If aftermarket, then you need to get a Bosch MAF
 
1 - 3 of 3 Posts
Top