SwedeSpeed - Volvo Performance Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
120 Posts
Discussion Starter · #1 ·
I picked up my '06 S60R in July and immediately had evolve springs installed.<br>Soon after, I noticed a squeek coming from the drivers front corner as well as general rattle/loose sounds and some clunking over bumps. Sounded like my old m3 when I had solid uppper strut mounts...ok for the track but not what you want for every day.<p>Well, I searched these forums and found that a lot of folks were complaining about similar sounds and there were many opinions but not much in the way of definitive solutions except that some recommended replacement of the upper strut bushing. I did not think this could be my problem since the car was new.<p>Anyway, I bounced the car up and down while parked and could definately hear and feel the upper strut mount squeeking. I pulled off the strut and studied it and found that the rubber upper spring perch was misaligned....it was allowing the top of the coil spring to rub against the metal cap that retains the upper bump stop (the PU foam donut at the top of the strut shaft).<p>I compressed the spring, realigned the rubber spring perch and VIOLA...no more squeeks, clunks, rattles thumps or anything bad...just a smooth and quite R.<p>So, I think that the design of these components makes them very suceptable to shifting during assembly or straight out miss-assembly. I hope this helps any of you out there that are having these suspension noises....they are NOT due to the shocks themselves as many folks seem to think.<p>Hope this helps any with a similar noise...I can enjoy my car again.
 

·
Registered
Joined
·
63,543 Posts
Re: I found the front strut squeek (dlp)

A constructive tech tip <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0">
 

·
Registered
Joined
·
3,846 Posts
Re: I found the front strut squeek (JRL)

... and on his first post. <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0"> <p>Sure beats the usual "I just bought an R. What C4 setting do I use to beat an S4?"
 

·
Registered
Joined
·
1,814 Posts
Re: I found the front strut squeek (StaggRLee)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>StaggRLee</b> »</i></TD></TR><TR><TD CLASS="quote">... and on his first post. <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0"> <p>Sure beats the usual "I just bought an R. What C4 setting do I use to beat an S4?"</TD></TR></TABLE><p>My favorites include:<br>What personalized license plate should I get?<br>or<br>What tires to buy?
 

·
Registered
Joined
·
1,814 Posts
Re: I found the front strut squeek (steamboatsig)

I had the same squeek, but the tech couldn't figure it out. So I had him put the stock front springs back on. I wish you were around then.
 

·
Registered
Joined
·
2,964 Posts
Re: I found the front strut squeek (steamboatsig)

You, for sure, win the 1st post award. Wow! Can't wait for your second... ha.
 

·
Registered
Joined
·
1,821 Posts
Re: I found the front strut squeek (StaggRLee)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>StaggRLee</b> »</i></TD></TR><TR><TD CLASS="quote">... and on his first post. <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0"> <p>Sure beats the usual "I just bought an R. What <B>C4</B> setting do I use to beat an S4?"</TD></TR></TABLE> <p>With the right amount of C4, I think you could "beat" just about every car out there. <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/biggrin.gif" BORDER="0"><p>Seriously, for the first post, that's amazing! Welcome to the site!
 

·
Registered
Joined
·
315 Posts
Re: I found the front strut squeek (dlp)

First of all, great post!<p>I think I have this very same problem. I have a popping/thumping sound when the car moves up and down over speed bumps and driveways. It's very annoying. The dealer has looked at it 3 times and they can't figure it out. I'll now try offering your solution and see what they say.<p>To add to my suspicions, oddly enough, the car didn't do this Sweden (OSD)- only after it was shipped to the U.S. did it start making this sound. Does Volvo install shhipping spacers in the springs when they ship their cars? I know BMW does. So could these spacers have screwed up the springs or the mount? Just a wild guess. <IMG NAME="icon" SRC="http://www.vwvortex.com/zeroforum_graphics/screwy.gif" BORDER="0"> <p>I'm getting tired of going back to the dealer. Even though it's free, I'd rather pay somebody to look at it and get it resolved once and for all. Any good independent shops in Los Angeles?<p>06 S60R (OSD)<br>03 325ci<br>
 

·
Registered
Joined
·
201 Posts
Great post!<p>I copied the entire thread and sent it off to the shop that installed my Evolve springs. We'll see if I can't get in there tomorrow and remedy my sqeaking/thumping.<p>Will def. post up results and give mad props if all goes well!
 
1 - 9 of 9 Posts
Top