SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
543 Posts
Discussion Starter #1 (Edited)
Hybrid battery not showing full range?

Anyone know what’s going on? After charging the car only says it can go like 7 miles, batt gauge seems ok.



Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
166 Posts
More information please. How long did it charge before you saw this? I see you were in hybrid mode and "d" mode. Did it say 7 miles of range as soon as you turned it on? Any additional info you can provide the better to see how everyone can help.
 

·
Registered
Joined
·
543 Posts
Discussion Starter #3 (Edited)
Hybrid battery not showing full range?

More information please. How long did it charge before you saw this? I see you were in hybrid mode and "d" mode. Did it say 7 miles of range as soon as you turned it on? Any additional info you can provide the better to see how everyone can help.
I just went out to the car, it has a full charge. Haven’t gone anywhere, only says 10 mile range. Also when driving this is all it gets. MY18, was getting 22.



Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
166 Posts
Weird. I would take it to the dealer. That is the only advice I have for you my friend.
 

·
Registered
Joined
·
166 Posts
That has to be a software issue. I can't see it being anything else.
 

·
Registered
Joined
·
543 Posts
Discussion Starter #7
That has to be a software issue. I can't see it being anything else.
I’m thinking it might be the battery, I can only get 10 miles out in pure mode driving normally. Would think if a software issue, it would adjust back up with less spirited driving, not completely hinder the range. It’s a major emissions issue if it’s not meeting their published ratings.

I see other posts that in the winter it drops more since the heater eats up power, but this is a much more drastic drop in range.

I check my charge logs on my charger and it’s charging a full 8kw still. Just seems the battery has lost its output capacity.



Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
166 Posts
I’m thinking it might be the battery, I can only get 10 miles out in pure mode driving normally. Would think if a software issue, it would adjust back up with less spirited driving, not completely hinder the range. It’s a major emissions issue if it’s not meeting their published ratings.

I see other posts that in the winter it drops more since the heater eats up power, but this is a much more drastic drop in range.

I check my charge logs on my charger and it’s charging a full 8kw still. Just seems the battery has lost its output capacity.



Sent from my iPhone using Tapatalk Pro
In my limited experience with this vehicle, but lots of long term experience with other hybrids, as the temps drop below 40 degrees, the battery performance drops significantly, particularly because of the inefficiencies of batteries in general in lower temps, but mostly because of the additional load for heating items. Now the the heat is not being demanded for the most part, I am easily seeing 18-24 miles on all EV range in pure and b modes engaged. However it does not appear that is the situation for you. I am interested in what your findings are.
 

·
Registered
Joined
·
543 Posts
Discussion Starter #9
Well xc is back in the shop again, after they reset everything the last time and got the range back to 19-20, it’s now back down again to around 14. Been there for over a week now, no word on what they are doing this time.


Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
6,434 Posts
Well xc is back in the shop again, after they reset everything the last time and got the range back to 19-20, it’s now back down again to around 14. Been there for over a week now, no word on what they are doing this time.


Sent from my iPhone using Tapatalk Pro
The estimated range number is probably related to how long you drive for daily trips. If you drive 20 miles each trip it should show normal range about 18.
 

·
Registered
Joined
·
383 Posts
Well xc is back in the shop again, after they reset everything the last time and got the range back to 19-20, it’s now back down again to around 14. Been there for over a week now, no word on what they are doing this time.


Sent from my iPhone using Tapatalk Pro
What does your receipt say they did to resolve it? I've owned a 2017 XC90 t8 and a 2020 XC90 t8 and it's never been below 17 miles after a full charge. I do live in SoCal so I don't really experience too much cold... Perhaps it's a battery cell or software issue. You need to be asking a dealer what they did to resolve with the first time and why it came back?
 

·
Registered
Joined
·
543 Posts
Discussion Starter #12
What does your receipt say they did to resolve it? I've owned a 2017 XC90 t8 and a 2020 XC90 t8 and it's never been below 17 miles after a full charge. I do live in SoCal so I don't really experience too much cold... Perhaps it's a battery cell or software issue. You need to be asking a dealer what they did to resolve with the first time and why it came back?
They contacted Volvo and reset some software last time. Yea it just started happening the last time i posted. Have had the car 2 years now and haven’t changed my driving habits. So something is up with the xc.


Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
938 Posts
My records show for 35F driving I've gotten 16.8 pure EV miles before the 2019 battery was depleted. I'm definitely curious what you find.
 

·
Registered
Joined
·
1,872 Posts
They contacted Volvo and reset some software last time. Yea it just started happening the last time i posted. Have had the car 2 years now and haven’t changed my driving habits. So something is up with the xc.


Sent from my iPhone using Tapatalk Pro
Have you been getting SW updates over the last couple of years? I recall having had that issue about 2 years ago. In my case it didn't charge up to full a couple of times and while the display showed not fully charged, it still showed full 20mi to discharge. Since then there have been updates to restore the full 20mi and lately ones to that more closely match driving cycle to discharge. Generally I've not seen a change in actual range for any given driving cycle.
 

·
Registered
Joined
·
543 Posts
Discussion Starter #15
Have you been getting SW updates over the last couple of years? I recall having had that issue about 2 years ago. In my case it didn't charge up to full a couple of times and while the display showed not fully charged, it still showed full 20mi to discharge. Since then there have been updates to restore the full 20mi and lately ones to that more closely match driving cycle to discharge. Generally I've not seen a change in actual range for any given driving cycle.
yeah, car was actually in for its maintenance about 2k before the issue and they did a full sw update at the time also.

Latest update, they called yesterday and have a BSM on order to replace?
 

·
Registered
Joined
·
3,432 Posts
I can confirm that my MY16 XC T8 has been in for service two weeks now with the similar set of issues.

Volvo and my dealer continue to investigate and hopefully there will be a resolution soon.


All the best from Minnesota USA,
A fine MY16 XC90 T8
 

·
Registered
Joined
·
543 Posts
Discussion Starter #18 (Edited)
I can confirm that my MY16 XC T8 has been in for service two weeks now with the similar set of issues.

Volvo and my dealer continue to investigate and hopefully there will be a resolution soon.


All the best from Minnesota USA,
A fine MY16 XC90 T8
Well got the car back, looked at the service notes, all they did was back date the BECM software (31483293)! wow and that took them a month to do! No modules replaced. did charge it and showed 18 for the range, 20 in pure. took it for a drive and it did get that range. hopefully it stays this time.
 

·
Registered
Joined
·
3,432 Posts
My car is back from service. Volvo and Borton Volvo both did a fine job diagnosing and resolving the hybrid and VCM/BECM issues. It turned out that the HVCH had an isolation fault, the electric A/C Compressor was intermittently shorting out, and there was a high resistance on the ground circuit on the BECM which inhibited communications within the hybrid system. Also, BECM and VCM software was reloaded. As a precaution and to verify, the hybrid battery sells were discharged, and deep / triple-charged. All of the 96 cells came back at 100%. The tech told me that the Hybrid Battery State of Health (longevity) and the Hybrid Battery State of Charge (remaining charge) were all at 100%. That was really great news for a MY16.

On the drive home, all seems to be working fine for a MY16 (that has the smaller hybrid battery). Although it took 4 weeks, I appreciate that extra effort and time that Borton's service dept and Volvo Tech Support took to diagnose and address the issue. Having a MY20 XC40 loaner was fun. My wife liked it for its size and agility for around town. That is another story, though.
 

·
Registered
Joined
·
6,434 Posts
Glad it is sorted out. So are the HVCH and A/C compressor replaced or fixed?

Does this mean the A/C was used intermittently to maintain coolant temperature due to HVCH heating up too much? Nice double drain of battery for nothing but extra heat under the hood. So any other symptom could help detect such issue? Was there extended run of cooling fans?

A battery coolant temperature reading will be very helpful.

Sent from my Z978 using Tapatalk
 
1 - 20 of 27 Posts
Top