SwedeSpeed - Volvo Performance Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Two nights ago I woke up to my 2005 S40's horn blaring. This was in the middle of a 3 hour rain storm. The car unlocked and I was unable to get it to stop, even with the key in the ignition. The dash read "Valet Mode On." The only way I was able to stop the horn blaring was to disconnect the battery.

The next morning I plugged the battery back in, and there was silence. I started the car without difficulty. It initially read "CRASH MODE," flickered to "Valet mode on" and then to "normal mode." The horn started again within a few minutes so I disconnected it and left it, assuming that if there was an electrical problem due to the excessive rain, maybe Id get lucky and it would evaporate.

This morning, day 3, I was able to plug the car in and it started fine. It ran quietly for about 10 minutes but then started flashing the hazard lights. The dash at this time showed a check engine light. Some intermittent honking started and she was once again shut down at the battery.

Anyone every see or hear of something similar? Any advise greatly appreciated... I cant find anything similar online!
 

·
Registered
Joined
·
4,185 Posts
Two nights ago I woke up to my 2005 S40's horn blaring. This was in the middle of a 3 hour rain storm. The car unlocked and I was unable to get it to stop, even with the key in the ignition. The dash read "Valet Mode On." The only way I was able to stop the horn blaring was to disconnect the battery.

The next morning I plugged the battery back in, and there was silence. I started the car without difficulty. It initially read "CRASH MODE," flickered to "Valet mode on" and then to "normal mode." The horn started again within a few minutes so I disconnected it and left it, assuming that if there was an electrical problem due to the excessive rain, maybe Id get lucky and it would evaporate.

This morning, day 3, I was able to plug the car in and it started fine. It ran quietly for about 10 minutes but then started flashing the hazard lights. The dash at this time showed a check engine light. Some intermittent honking started and she was once again shut down at the battery.

Anyone every see or hear of something similar? Any advise greatly appreciated... I cant find anything similar online!
How's your battery?
 

·
Registered
Joined
·
658 Posts
Didn't know CHRISTINE haunted Volvo cars.
 

·
Registered
Joined
·
90 Posts
I had the sunroof leak into the foot wells awhile back and when I was cleaning up there was some electronics that were damp. I haven't had any problems but I'm curious if these things got wet from a possible leak that they could have shorted out and caused something like this to happen? Not sure what the electronics are for either?
 
1 - 4 of 4 Posts
Top