SwedeSpeed - Volvo Performance Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
For the past few days our 2004 XC70 has been revving to roughly 2K on start-up, holding for a bit, dropping to 1.5K then dropping to 1K after about 30 seconds. It didn't do this at all when we first bought it, but now that we are week in it seems to happen daily or multiple times daily. 2K underhood at start-up is considerably louder under hood than the 1K we were previously used to. Looking for any insight as to cause or cure.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
So does the car use ambient temperature as a trigger for when to use this warm-up? I just thought it odd that it didn't do it for a week and now does it daily. It does coincide with the recent lower temperatures in the Northeast US. If it is normal behavior I am fine with it.
 

·
Registered
Joined
·
11,927 Posts
So does the car use ambient temperature as a trigger for when to use this warm-up? I just thought it odd that it didn't do it for a week and now does it daily. It does coincide with the recent lower temperatures in the Northeast US. If it is normal behavior I am fine with it.
Yes. If the engine or ambient temperature is warm, the idle speed after start will be close to normal.
If the engine and ambient temperature are cold, you will get a fast idle for some number of seconds. Your owners manual probably mentions this somewhere.
 

·
Registered
Joined
·
133 Posts
This should be explained in the owners manual - at least it is for my '13 S60.


Sent from my iPhone using Tapatalk
 
1 - 6 of 6 Posts
Top