SwedeSpeed - Volvo Performance Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey guys I have an 05 s40 2.4i with about 155k miles on it.

Today on my commute home I noticed a high pitched squealing noise coming from the engine bay.

See attached video:

View My Video


I notice when I turn the car on, the noise doesn't start for 1-2 seconds, so that leads me to believe it's nothing related to any belts or pullets but of course, I could be wrong.

Is it the PCV? Any other ideas? Search yielded some similar problems but with a VERY different noise than what I am experiencing.

Thank you for understanding why I am posting and for your help!
 

·
Registered
Joined
·
1,182 Posts
Sounds like the PCV noise to me. If it goes away when you pull the dipstick, that's most likely the case.
 

·
Registered
Joined
·
1,199 Posts
Could be the belt tensioner bearing or an accessory belt. Does it change when you turn the steering wheel? Only way to know for sure is to take the belt off and see if it goes away. If it does, spin all the accessories by hand and check for any wobble or roughness. At 155k you definitely need to do your pcv though regardless.

Sent from my SHIELD Tablet using Tapatalk
 

·
Registered
Joined
·
59 Posts
My car had the same issue recently, ended up being the pcv. In fact, it sounded like that! Pull up the dipstick, if it stops then the pcv is at fault.
 

·
Registered
Joined
·
245 Posts
My car had the same issue recently, ended up being the pcv. In fact, it sounded like that! Pull up the dipstick, if it stops then the pcv is at fault.
I second that - give it a shot. Pretty easy diagnosis.
 

·
Registered
Joined
·
1,182 Posts
Thanks for replying. Do you have any experience replacing this?

Cheers
It was replaced on my car under warranty. There's a thread 1 or 2 pages back called Oil Filter Housing Replacement or similar that details the process. Doesn't seem terribly difficult
 
1 - 7 of 7 Posts
Top