SwedeSpeed - Volvo Performance Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter · #1 ·
Hi everyone, im hoping to just get a little insight on a car I just purchased. I bought a 2006 geartronic S60R with 108k from an older lady "2nd owner" last week. Car has a super solid service history at my local dealer. Didn't ever have the timing belt done so that was basically the first thing I arraigned to have done. So the day before it was scheduled to go in for the belt I was driving the car on the highway in manual mode just playing around. Was in 3rd gear and got on it about 3/4 throttle then pushed it up into 4th with a little clunk from the tranny, then up into 5th with a little harder of a clunk. Immediately following the "no oil pressure warning pull over ASAP" light came on. So that's what I did. Checked the oil immediately and let it cool for a bit and kept checking the dipstick level which looked fine. I Was worried to do any damage so I had it towed to the dealer. They checked it all out and found no stored codes or any issues what so ever. Oil level was fine. They changed the oil and then did the timing belt while it was there. I was informed that it could be the oil sensor but they wanted to help me out and see if the problem persisted before I had that replaced. I also informed them of the clunk in the tranny and asked them to give that a peek. They drove the car and the mechanic could not replicate the transmission noise, they did however find that the lower trans mount was junk so they changed that. Took the car home and noticed that the transmission felt ok but when manually down shifting from 3-2 it does a weird pulsating downshift. Makes about 3 shutters as its downshifting!! Does it every single time from 3-2 and no other gears. I've done a ton of research and hear about people flushing the trans , changing the transmission valve body, or having it reflashed. Not sure what route I should take. I did also notice that the upper motor mount bushing was torn so I ordered the poly replacement from Evolve. Should be in this week coming. I'm not sure if the play in the upper mount would effect the transmissions behavior!?!? Lastly the no pressure oil light came on again yesterday after some pretty spirited driving. Pulled over shut the car off, checked for oil which it had, started it back up with no light on anymore, and drove it home. Any advice would be greatly appreciated. The car is really a nice clean car and I would just like it to be fully sorted. Thanks
 

·
Registered
Joined
·
6,562 Posts
Check the transmission serial number. If it falls within a certain range the valve body is likely the culprit. Did the low oil pressure lamp illuminate? If not I'd say oil level sensor sounds about right.
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #3 ·
Check the transmission serial number. If it falls within a certain range the valve body is likely the culprit. Did the low oil pressure lamp illuminate? If not I'd say oil level sensor sounds about right.

Thanks for the reply. Ya I guess I need to check the transmission serial number tomorrow. I guess the 06F number would mean it has the junk valve body as opposed to the better 06J? My concern is how much this replacement would cost me. Amy ideas? The only light that came on the dash said I believe no oil pressure stop ASAP. It never had a low level warning.
 

·
Super Moderator
Joined
·
8,698 Posts
You can buy a new or refurbished valve body with the appropriate updates applied and then you'll have to pay the labor to have it replaced (assuming you can't do it yourself). I would estimate ~$1100-$2,000 total, but that's a guess.
 

·
Super Moderator
Joined
·
8,698 Posts
2006 and 2007 S60R V70R Automatic Geartronic Transmission Aisin Warner TF80SC Valve Body Rebuilt or New Replacement:

Cobra Transmission - New - $783.99
http://cobratransmission.com/tf80sc-valve-body-volvo-305017-1

Ream Man Valve Bodies - Remanufactured - $674.48
http://www.reamman.com/products/149-tf80sc.aspx

Macko Transmission Parts - Rebuilt - $1,273.09
http://www.makcotransmissionparts.com/P39740-2.html

Before I ordered any of these, I would be absolutely sure to contact the vendor to verify correct fitment for our caRs.
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #6 ·
Just went out and checked and the transmission code starts with 05J. Looks like a have the crap valve body! Wondering if a flush and possible reflash could be a good fix though. My problem doesn't sound nearly as bad as some of the horror stories I've been reading.
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #7 ·
2006 and 2007 S60R V70R Automatic Geartronic Transmission Aisin Warner TF80SC Valve Body Rebuilt or New Replacement:

Cobra Transmission - New - $783.99
http://cobratransmission.com/tf80sc-valve-body-volvo-305017-1

Ream Man Valve Bodies - Remanufactured - $674.48
http://www.reamman.com/products/149-tf80sc.aspx

Macko Transmission Parts - Rebuilt - $1,273.09
http://www.makcotransmissionparts.com/P39740-2.html

Before I ordered any of these, I would be absolutely sure to contact the vendor to verify correct fitment for our caRs.


Thanks for this information!!!! Sounds like it's could cost a pretty penny!!!
 

·
Registered
Joined
·
1,377 Posts
Try a drain and fill with valvoline maxlife synthetic ATF. You can find it at walmart for $17 a gallon. Also clean your MAF and replace your upper mount. I would try to verify your valve body is gone before you drop 1-2grand

Sent from my SAMSUNG-SGH-I337 using Tapatalk
 

·
Super Moderator
Joined
·
8,698 Posts
I just read back through your full post. There's nothing in there that would make me rush out to get the transmission valve body replaced (at least yet). You need to get your oil pressure issue fixed as a priority. Here's the TNN about the valve body:

TNN43-53-2006-12-21 Title: Auto Trans - TF80-SC Diagnostic Information Summary - Valve Body Replacement.
This document summarizes customer complaints related to the 6 speed Automatic Transmission (TF80-SC) and should be used together with the information in VIDA.

The Valve Body should be replaced to address the following symptoms:
1. Customer complaints about 2-3 upshift quality. The shift may be described as harsh, or as a shudder. The symptom is usually more apparent during the first few minutes of driving after a cold start.
2. Customer complaints of shudder when slowing down, just before coming to a stop. The symptom may also be described as a harsh downshift just before coming to a stop.
3. Neutral condition in 4th, 5th & 6th gear; normal behavior in 1st, 2nd, 3rd & Reverse. One or more of the following DTCs (Diagnostic Trouble Codes) may be present: P073400, P073500, P072900, P089600.
4. Neutral condition in all gears except 5th & Reverse, usually with DTC P273300 set. DTCs for gear ratio(s) may also be set such as P073000, P073100, P073200, or P073400.
Note: Transmissions starting with serial number 06J and later already have the latest valve body which is designed to prevent these symptoms.

You can live with a slowly failing valve body for a long time before needing to jump into it.
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #10 ·
Thanks again for your input. I really appreciate it. I'm for sure gonna have the oil pressure situation addressed. Hoping that maybe a tranny flush will clean things up a bit. Like I said its not nearly as bad as others problems people are having.
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #11 ·
Anyone know what the dealer might charge for the transmission flush? I'm
Gonna call and find out tomorrow but curiosity is gonna pick at my brain all
Day today being sunday!! Haha. The dealer quoted me $450 and some change to replace the oil pressure sensor. Is that something i could do myself? I'm a pretty descent DIY guy!!!
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #12 ·
Try a drain and fill with valvoline maxlife synthetic ATF. You can find it at walmart for $17 a gallon. Also clean your MAF and replace your upper mount. I would try to verify your valve body is gone before you drop 1-2grand

Sent from my SAMSUNG-SGH-I337 using Tapatalk
Yup deifinity a good point!! Thanks
 

·
Registered
Joined
·
8,055 Posts
I had my low oil pressure light wink at me a few times when the engine was hot and idling before I had to rebuild my motor. For why that was the case, see my refurb link below.

Hopefully in your case it would be sludge instead of metal causing the issue.
 
1 - 13 of 13 Posts
Top