SwedeSpeed - Volvo Performance Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I am in a rather serious predicament here.

Have removed both rear strut assemblies, and successfully taken the coils/springs off. Problem now is getting it back together. Issue is that when assembled, I can’t compress the rubber washer that sits on top of the top strut enough to thread the bolt onto the tip of the strut.
What is the trick to getting to compressing that washer and getting enough thread visible to get the nut back on?
Did I reassemble something wrong on in the top of the strut beneath the strut mount?
Anyone have a good diagram of how the components go back on the strut, beneath the upper strut mount?
Do I have the long bushing in the wrong place?

Any help would be appreciated.
 

·
Premium Member
Joined
·
19,952 Posts
I am in a rather serious predicament here.

Have removed both rear strut assemblies, and successfully taken the coils/springs off. Problem now is getting it back together. Issue is that when assembled, I can’t compress the rubber washer that sits on top of the top strut enough to thread the bolt onto the tip of the strut.
What is the trick to getting to compressing that washer and getting enough thread visible to get the nut back on?
Did I reassemble something wrong on in the top of the strut beneath the strut mount?
Anyone have a good diagram of how the components go back on the strut, beneath the upper strut mount?
Do I have the long bushing in the wrong place?

Any help would be appreciated.
Welcome to Swedespeed, Rich.

If the problem still exists post some pics so we can bemuse with you.

Thanks.

George Dill
 
1 - 2 of 2 Posts
Top