SwedeSpeed - Volvo Performance Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
258 Posts
Discussion Starter · #1 ·
Yea, sooo i spent all morning installing my 55w. 4300k HID kit from SharpHID.com. And well, i turn the car on, and they work fine....but for only 10 seconds. I have 2005 S60 T5, 55w kit, and cancelers. What to dooooo? <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/confused.gif" BORDER="0">
 

·
Registered
Joined
·
2,621 Posts
Re: Help......HID's wont work :/ (Max Wells)

check for blown fuses as anything aftermarket can cause issues. <br>Did your S60 come with Zeon's? If so you may be overloading the circuit as stock lamp draw 35W IIRC.
 

·
Registered
Joined
·
258 Posts
Discussion Starter · #3 ·
Re: Help......HID's wont work :/ (Oceans60R)

hmmmm k......and no, its a 05 S60 T5.. im double posting to get more feedback lol. Ive also herd about a battery harness?
 

·
Registered
Joined
·
2,621 Posts
Re: Help......HID's wont work :/ (Max Wells)

I'm not real familure with any aftermarket kits but anything drawing more current that the stock harness is fused for can cause issues not to mention trouble with the CEM.
 

·
Registered
Joined
·
258 Posts
Discussion Starter · #5 ·
Re: Help......HID's wont work :/ (Oceans60R)

yeaaaaa.....im just not used to this..i went from a generic nissan altima se-r....to the amazing car...wich has taught me a lesson on "aftermarket parts" haha
 

·
Registered
Joined
·
7,954 Posts
Read the blogs on Sharphid site, sounds like a problem with the car's computer. But its fixable.
 

·
Registered
Joined
·
1,568 Posts
Re: Help......HID's wont work :/ (Max Wells)

Like OceanS60R stated check your fuses. If they are blown then your fuses might not be high enough.
 

·
Registered
Joined
·
258 Posts
Discussion Starter · #8 ·
Re: Help......HID's wont work :/ (pie_ya)

mmk...sooo but if the fuses were blown, wouldent that cause the lights to not come on at all? seeing the come on for 10 seconds and the flicker off? <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/confused.gif" BORDER="0">
 

·
Registered
Joined
·
497 Posts
Re: Help......HID's wont work :/ (Max Wells)

I have the same car, with the same kit, with the same problem.<br>If you buy the battery harness, your HID's will stay on. You will also have the "bulb out message". There is no way to get rid of that message.<br>I decided to leave my stock bulbs in....
 

·
Registered
Joined
·
658 Posts
I had the 10 second problem when I added hid's to my old 850. On that car what i'd do is as soon as they shut off i'd turn the headlights to parking light position then back on quickly then the hids would stay on after that.<p>The relay / battery harness kit should solve it.
 
1 - 10 of 10 Posts
Top