SwedeSpeed - Volvo Performance Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello, I'm interested in purchasing an 04 s60r but it's got something funky going on with it that I haven't came across with my 05 R. Guy is stating that the water pump failed on the vehicle so the head gasket was replaced along with a new head from a donor car. But the vehicle now won't start displaying the reduced engine performance and start prevented messages. Vehicle supposedly has fuel spark and compression but the numbers he gave me for the compression test seem to be a bit off just wanted to get some oppinions on wether or not the vehicle was timed properly or not. He has vida and says they're are no active codes besides the sum. Test compression test results were. 120, 135, 120, 150, 150. Is this what is preventing the vehicle from running or are we looking at some sort of failed module.
 

·
Registered
Joined
·
134 Posts
Hello, I'm interested in purchasing an 04 s60r but it's got something funky going on with it that I haven't came across with my 05 R. Guy is stating that the water pump failed on the vehicle so the head gasket was replaced along with a new head from a donor car. But the vehicle now won't start displaying the reduced engine performance and start prevented messages. Vehicle supposedly has fuel spark and compression but the numbers he gave me for the compression test seem to be a bit off just wanted to get some oppinions on wether or not the vehicle was timed properly or not. He has vida and says they're are no active codes besides the sum. Test compression test results were. 120, 135, 120, 150, 150. Is this what is preventing the vehicle from running or are we looking at some sort of failed module.
That sure does sound like it's not timed correctly. As for the compression numbers, they are useless IF the car isn't timed correctly.
 

·
Registered
Joined
·
6,605 Posts
I think the bigger problem is the head was replaced... It likely has a cracked block. The start prevent message would imply a ground or voltage issue.
 
1 - 3 of 3 Posts
Top