SwedeSpeed - Volvo Performance Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
New to volvos I've owned mine for about 20 hrs. It's a 78 245 with 286000 on the clock just a baby by volvo standards lol.It's a cream 4speed W/Overdrive not a dent on the body a few scratchs but thats it. It has some problems but what 30+ year old car doesn't. very little minor surface rust. Even the battery tray is good. Paid 600 for it.:)


=
 

·
Premium Member
Joined
·
19,953 Posts
New to volvos I've owned mine for about 20 hrs. It's a 78 245 with 286000 on the clock just a baby by volvo standards lol.It's a cream 4speed W/Overdrive not a dent on the body a few scratchs but thats it. It has some problems but what 30+ year old car doesn't. very little minor surface rust. Even the battery tray is good. Paid 600 for it.
Welcome to Swedespeed, David.

Share some pics and history on your new 240 wagon along with info on what needs fixing.

Thanks.

George Dill
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
The people I bought it from said It was there daily driver up to a year ago but it was just sitting for the last year. It accually runs pretty good but doesn't like to idle when it's cold after it gets up to temp it's fine. what needs fixin where to start lol. the tach doesn't work the temp gauge doesn't work the radio. The rear hatch only opens from the inside the rear passenger side door doesn't open the heater is always on the air conditioner doesnt work niether does the fan.The overdrive doesn't work and I'm sure theres more I just haven't found it yet. I don't have any pics yet but will post some soon.
 
1 - 3 of 3 Posts
Top