SwedeSpeed - Volvo Performance Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hello,

new ( ~ 1 month) 2016 xc90 momentum plus with 5500km. Loving this car to death, having come from a much loved 2008 xc70.

interesting issue today on way home from work - I was a bit hot so adjusted temp lower. Fan speed increased, however vent temp remained static, and no air from face vents. once stopped at home, tried every adjustment possible. No response whatsoever to vent selection or temp, no defrost, or face air, only feet. did not mess with rear climate other than to turn off. Repeated key cycling, had no effect. any thoughts before I head to dealer?

Chris
 

·
Registered
Joined
·
1,732 Posts
Hello,

new ( ~ 1 month) 2016 xc90 momentum plus with 5500km. Loving this car to death, having come from a much loved 2008 xc70.

interesting issue today on way home from work - I was a bit hot so adjusted temp lower. Fan speed increased, however vent temp remained static, and no air from face vents. once stopped at home, tried every adjustment possible. No response whatsoever to vent selection or temp, no defrost, or face air, only feet. did not mess with rear climate other than to turn off. Repeated key cycling, had no effect. any thoughts before I head to dealer?

Chris
I've not experienced that on my XC90 - but I did have a similar problem on a previous Subaru. Was a stuck damper - simple fix. Hope your issue is resolved quickly.
 
1 - 2 of 2 Posts
Top